Référence externe - comment les gérer

Bastien43

XLDnaute Occasionnel
Bonjour,

J'ai un fichier excel "TEST" qui reprend les prix unitaires (PU) de plusieurs autres fichiers excel (références externes). Je mets les documents en pièces jointes.

Cependant, toutes les références externes n'existent pas encore car elles ne sont pas encore créées.

Est-ce possible d'éviter le message d'erreur à l'ouverture du fichier "TEST" : problème de mise à jour références externes...

ou quelles formules dans la cellule me permettrait d'éviter le problème de référence ?

Je vous remercie,
Cordialement,
Bastien
 

Pièces jointes

  • PU1.xlsx
    8.7 KB · Affichages: 6
  • PU2.xlsx
    8.7 KB · Affichages: 4
  • TEST.xlsx
    17.7 KB · Affichages: 6

njhub

XLDnaute Occasionnel
Bonjour Bastien43,

Pour éviter les références externes, le plus simple
serait d'intégrer vos listes de prix (PU1 & PU2) au fichier "Test".

Vous avez des millions de cellules disponibles dans un seul fichier,
pourquoi multiplier les fichiers à 2 cellules utiles...?
 

patricktoulon

XLDnaute Barbatruc
bonsoir
change le "1" pour les cellules suivantes et remplace "absent" par ce que tu veux même rien "" si tu veux
revois les vrais chemins j'ai fait les test chez moi
=SIERREUR(SI(A2="";"";'C:\Users\polux\Downloads\[PU1.xlsx]Feuil1'!$E$3);"absent")
 

Statistiques des forums

Discussions
313 316
Messages
2 097 094
Membres
106 836
dernier inscrit
ChristopheDF