recherchev

P

phil62

Guest
Bonjour,

J'utilise la fonction recherchev pour aller chercher des valeures dans d'autres onglets.

Je rencontre le souci suivant :
Dans ma base j'ai en 1ere colonne
1
2
3
4
5
6
7
8
9
10
Pour moi la formule fonctionne sauf pour le cas ci dessous
Pourquoi lorsque que la valeur de 3 qui n'existe peux être pas dans l'onglet suivant, le formule va me cherché la valeure précédent le 3. Je préfére avoir 0 si possible, avez vous une soluce pour moi ?

Merci d'avance ?
 

2passage

XLDnaute Impliqué
Bonjour,

Il faut préciser que tu ne souhaites pas de valeur approchante (le FAUX à la fin). MAis du coup, il faut intercepter l''erreur' quand il ne trouve pas. Ca donne

=si(estna(recherchev(valeur cherchée; base;colonne retour;faux)); '0'; recherchev(valeur cherchée; base;colonne retour;faux))

A+
 

Sylvie

XLDnaute Accro
Bonjour Phil62

si tu veux eviter que le fonction RECHERCHEV ne te retourne la valeur inférieure à 3 si le critère de recherche est absent, il faut que le dernier argument de ta fonction soit un 0 et non pas 1. Par contre, si ton critère est absent tu auras la valeur N/A.
Pour éviter ce message d'erreur tu pourras imbriquer les fonctions SI et RECHERCHEV par exemple comme ceci :
en A1 mon critère de recherche
en F17: G20 la matrice de recherche
=SI(ESTNA(RECHERCHEV(A1;F17:G20;2;0));'';RECHERCHEV(A1;F17:G20;2;0))

Bonne journée


EDITION
oupss ... je n'avais pas vu ta réponse 2nd passage !

Message édité par: sylvie40, à: 29/07/2005 10:26
 

Statistiques des forums

Discussions
312 913
Messages
2 093 534
Membres
105 751
dernier inscrit
fred13340