Recherche double critère

sessef1

XLDnaute Nouveau
bonjour,

Je voualais savoir s'il etait possible de faire une recherche avec deux critères.
Je vous expose mon problème.
Dans la premiere feuille j'ai un tableau au figure en
colonne A = Nom
Colonne B = Prenom
Colonne C = Matricule

Dans la deuxième feuille :
Colonne A = je dois retrouver le matricule (formule a faire)
Colonne B = Nom
Colonne C = Prénom
Colonne D = Type de congés

Je vous remercie pour vos réponses ou proposition
 

Pièces jointes

  • recherche double.xls
    18 KB · Affichages: 270
  • recherche double.xls
    18 KB · Affichages: 305
  • recherche double.xls
    18 KB · Affichages: 311

Efgé

XLDnaute Barbatruc
Re : Recherche double critère

Bonjour sessef1,
En partant du principe qu'une personne ne peut avoir qu'un seul matricule :
Code:
=SOMMEPROD(('Table Matricule'!$A$2:$A$53=$B2)*('Table Matricule'!$B$2:$B$53=$C2)*'Table Matricule'!$C$2:$C$53)
A mettre en A2 feuille "Type Congz" et à recopier vers le bas.
Cordialement
 

Sofhy

XLDnaute Occasionnel
Re : Recherche double critère

Bonjour,

Une autre possibilité :
Code:
=RECHERCHEV($C2;DECALER('Table Matricule'!$A$1;EQUIV($B2;'Table Matricule'!$A$2:$A$53;0);1;NB.SI('Table Matricule'!$A$2:$A$53;$B2);4);COLONNE()+1;0)

A++
Sofhy
 

Statistiques des forums

Discussions
312 928
Messages
2 093 697
Membres
105 787
dernier inscrit
BABOU79