Autres Recherche dans les colonnes mais aussi dans plusieurs lignes pour un même nom

chelle2

XLDnaute Nouveau
Bonjour à tous,
J'ai besoin d'aide, je suis entrain de me faire un petit fichier sur la géomancie mais la je suis coincée.

Je vous mets le fichier pour vous montrer
En faite j'essaie de récupérer les points au bon endroit selon la figure demandé, Ex ; Conjuctio et du coup toute la figure (les lignes et les colonnes qui vont avec ce nom)
mais j'y arrive pour la 1ère ligne de chaque figure mais je n'arrive pas a récupérer les points au bon endroit des autres lignes de la même figure.

J'espère que vous me comprendrez :) Merci par avance

Bonne soirée
Michelle
 

Pièces jointes

  • Géomancie.xlsx
    16.2 KB · Affichages: 3

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Chelle, et bienvenu sur XLD,
En PJ un essai avec ce que j'ai compris :
1- Pour le tableau de droite il est peut être plus simple de se passer de fonction matricielle, avec simplement :
VB:
=SI(Y7=1;"•";"")
2- Pour la recherche, un exemple avec :
Code:
=INDEX($V:$V;EQUIV(E$18;$U:$U;0))
Les formules changent pour les 9 cellules, soit en ligne, soit en colonne.

On duplique les motifs en copiant le tableau rose sur une autre plage, les formules s'adaptent.
 

Pièces jointes

  • Géomancie.xlsx
    16.5 KB · Affichages: 2

chelle2

XLDnaute Nouveau
Bonjour Chelle, et bienvenu sur XLD,
En PJ un essai avec ce que j'ai compris :
1- Pour le tableau de droite il est peut être plus simple de se passer de fonction matricielle, avec simplement :
VB:
=SI(Y7=1;"•";"")
2- Pour la recherche, un exemple avec :
Code:
=INDEX($V:$V;EQUIV(E$18;$U:$U;0))
Les formules changent pour les 9 cellules, soit en ligne, soit en colonne.

On duplique les motifs en copiant le tableau rose sur une autre plage, les formules s'adaptent.
Bonjour Sylvanu, Un grand merci, oui c'est super ce que tu as fais :)

Je t'ais remis le fichier pour te demander autre chose, si tu peux regarder et me dire comment faire je te remercie vraiment beaucoup.
j'ai expliquer dans le fichier

Michelle
 

Pièces jointes

  • Géomancie.xlsx
    20.5 KB · Affichages: 2

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Chelle,
J'ai supposé que, contrairement aux mathématiques, 0 n'est pas un nombre pair ?
Donc dans ce cas :
VB:
=SI(ET(EST.PAIR(NB.SI(I14;"•")+NB.SI(L14;"•")+NB.SI(O14;"•")+NB.SI(R14;"•"));NB.SI(I14;"•")+NB.SI(L14;"•")+NB.SI(O14;"•")+NB.SI(R14;"•")<>0);"•";"")
Si 0 est un nombre pair alors :
Code:
=SI(EST.PAIR(NB.SI(I14;"•")+NB.SI(L14;"•")+NB.SI(O14;"•"));"•";"")
 

Pièces jointes

  • Géomancie (V2).xlsx
    20.7 KB · Affichages: 3

chelle2

XLDnaute Nouveau
Bonjour Chelle,
J'ai supposé que, contrairement aux mathématiques, 0 n'est pas un nombre pair ?
Donc dans ce cas :
VB:
=SI(ET(EST.PAIR(NB.SI(I14;"•")+NB.SI(L14;"•")+NB.SI(O14;"•")+NB.SI(R14;"•"));NB.SI(I14;"•")+NB.SI(L14;"•")+NB.SI(O14;"•")+NB.SI(R14;"•")<>0);"•";"")
Si 0 est un nombre pair alors :
Code:
=SI(EST.PAIR(NB.SI(I14;"•")+NB.SI(L14;"•")+NB.SI(O14;"•"));"•";"")
Coucou Sylvanu, non la ça fait pas car moi ce que je veux c'est que quand le total de la ligne des 4 figures donne un nombre pair alors je mets 2 points et que quand le total est un nombre impair alors c'est 1 point.

J'espère que tu comprend, la sur la 1ère ligne le total des point est 4 donc il faut 2 points
sur la 2ème ligne le total des point est 6 donc il faut 2 points
et sur la 3ème ligne le total des points est 5 donc il faut 1 point
Je sais c'est compliqué et je suis perdu j'avoue
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
C'est très simple, c'est la même formule en remplaçant "•" par 2 et "" par 1 :
VB:
=SI(ET(EST.PAIR(NB.SI(I14;"•")+NB.SI(L14;"•")+NB.SI(O14;"•")+NB.SI(R14;"•"));NB.SI(I14;"•")+NB.SI(L14;"•")+NB.SI(O14;"•")+NB.SI(R14;"•")<>0);2;1)
 

Pièces jointes

  • Géomancie (V3).xlsx
    20.7 KB · Affichages: 2

chelle2

XLDnaute Nouveau
C'est très simple, c'est la même formule en remplaçant "•" par 2 et "" par 1 :
VB:
=SI(ET(EST.PAIR(NB.SI(I14;"•")+NB.SI(L14;"•")+NB.SI(O14;"•")+NB.SI(R14;"•"));NB.SI(I14;"•")+NB.SI(L14;"•")+NB.SI(O14;"•")+NB.SI(R14;"•")<>0);2;1)
Coucou Sylvanu, merci de ton aide. Je pense qu'on ne sait pas bien compris, en faite je ne veux pas remplacer les points par des nombre.
Je t'ai mis une capture d'écran qui te montre comment je le veux.
Dans la 1ère ligne des 4 premières figures, il faut pouvoir additionner combien il y a de point : Ex . dans la 1ère ligne des 4 premières figures il y à 4 points ; donc je voudrais que sur la 1ère ligne de la 5ème figure il y est
. . (2 points) (comme c'est un chiffre paire)
et pareil pour les autres lignes.

Je suis compliquée je sais :)
 

Pièces jointes

  • 2.jpg
    2.jpg
    66.4 KB · Affichages: 6

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour,
j'aurais juste une dernière question.
Juste la dernière, promis ?
Un essai en PJ.
Pour trouver le 5eme motif, j'ai créé des "signatures" pour chaque motif, puis la même chose pour le 5eme motif et fais une recherche pour identification avec :
VB:
Signature :
=C14&D14&E14&C15&D15&E15&C16&D16&E16&C17&D17&E17
Recherche :
=SIERREUR(INDEX(AA:AA;EQUIV(C18;AA:AA;0)-3);"Inconnu")
 

Pièces jointes

  • Géomancie (V5).xlsx
    22 KB · Affichages: 2

chelle2

XLDnaute Nouveau
Bonjour,

Juste la dernière, promis ?
Un essai en PJ.
Pour trouver le 5eme motif, j'ai créé des "signatures" pour chaque motif, puis la même chose pour le 5eme motif et fais une recherche pour identification avec :
VB:
Signature :
=C14&D14&E14&C15&D15&E15&C16&D16&E16&C17&D17&E17
Recherche :
=SIERREUR(INDEX(AA:AA;EQUIV(C18;AA:AA;0)-3);"Inconnu")
Bonjour Sylvanu, oui promis c'était la dernière :) En tout cas un grand merci à toi, tu as du talent. Moi j'essayais depuis des heures de trouver quelque chose et rien. Encore merci et bonne journée

Michelle
 

Discussions similaires

Statistiques des forums

Discussions
313 221
Messages
2 096 323
Membres
106 570
dernier inscrit
caisse