Recherche avec plusieurs conditions

coyane

XLDnaute Nouveau
Bonjour,

Je cherche à restituer dans des données dans le fichier joint.
Dans l'onglet "base t", je voudrais récupérer dans la colonne F les données de l'onglet "csi_cci" (colonne C) avec une usine et gamme identique .
Idem pour la colonne G avec la colonne D.

Merci pour vos suggestions et bonnes fêtes de fin d'année à tous.
 

Pièces jointes

  • test.xls
    81 KB · Affichages: 47
  • test.xls
    81 KB · Affichages: 49
  • test.xls
    81 KB · Affichages: 48

Gareth

XLDnaute Impliqué
Re : Recherche avec plusieurs conditions

Bonjour,

Ci-joint une solution macro.
Il faut vérifier l'intégrité de tes bases.
LE TEIL(F GRIS) n'est pas libellé de la meme façon dans "csi_cci" et "base t"
 

Pièces jointes

  • test.xls
    102.5 KB · Affichages: 43
  • test.xls
    102.5 KB · Affichages: 40
  • test.xls
    102.5 KB · Affichages: 43

R@chid

XLDnaute Barbatruc
Re : Recherche avec plusieurs conditions

Bonsoir @ tous,
Salut Gareth,
une variante par formule,
en F2,
Code:
=SIERREUR(INDEX(csi_cci!C$2:C$19;EQUIV('base t'!$A2&'base t'!$B2;STXT(csi_cci!$A$2:$A$19;TROUVE("-";csi_cci!$A$2:$A$19)+2;99)&csi_cci!$B$2:$B$19;0));"")
@ valider par Ctrl+Maj+Entree
@ tirer vers le bas et vers la droite
@ +
 

Discussions similaires