XL 2019 Problème avec SIERREUR(RECHERCHEV("*"&$E$35&"*";plagelibelAN;1;0)

DédéW83

XLDnaute Junior
Bonjour à tous, je suis en train de m'enliser avec cette formule qui ne me trouve pas les bons résultats.
=SI($A$53=1;SI($E$35>"";SIERREUR(RECHERCHEV("*"&$E$35&"*";plagelibelAN;1;0);SIERREUR(RECHERCHEV("*"&$E$35&"*";plagelibelopAN;1;0);SIERREUR(SIERREUR(RECHERCHEV($G$35;plagedebAN;1;0);RECHERCHEV($G$35;plagecredAN;1;0));"Non trouvé")))))
Dans ma recherche dans le relevé de banque, si je tape : CARREFOUR ? Il ne me renvoie que CARREFOUR BANQUE mais pas les CB dans CARREFOUR tout court.
Fichier example ci joint. Quelqu'un aurait une idée où trouver l'erreur?
Merci par avance ! DédéW83.
 
Solution
Bonjour à tous,

A essayer en C13 formule matricielle
VB:
=SIERREUR(SIERREUR(INDEX(O$2:O$99;PETITE.VALEUR(SI(plagelibelAN=$F$11;LIGNE(plagelibelAN)-1);LIGNES($1:1)));SIERREUR(INDEX(O$2:O$99;PETITE.VALEUR(SI(plagedebAN=$F$11;LIGNE(plagedebAN)-1);LIGNES($1:1)));INDEX(O$2:O$99;PETITE.VALEUR(SI(plagecredAN=$F$11;LIGNE(plagecredAN)-1);LIGNES($1:1)))));"")

copier vers le bas et la droite

JHA

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer en C13 formule matricielle
VB:
=SIERREUR(SIERREUR(INDEX(O$2:O$99;PETITE.VALEUR(SI(plagelibelAN=$F$11;LIGNE(plagelibelAN)-1);LIGNES($1:1)));SIERREUR(INDEX(O$2:O$99;PETITE.VALEUR(SI(plagedebAN=$F$11;LIGNE(plagedebAN)-1);LIGNES($1:1)));INDEX(O$2:O$99;PETITE.VALEUR(SI(plagecredAN=$F$11;LIGNE(plagecredAN)-1);LIGNES($1:1)))));"")

copier vers le bas et la droite

JHA
 

Pièces jointes

  • DédéW83- date pour un libellé- v2.xlsx
    114.2 KB · Affichages: 8

DédéW83

XLDnaute Junior
Bonjour à tous,

A essayer en C13 formule matricielle
VB:
=SIERREUR(SIERREUR(INDEX(O$2:O$99;PETITE.VALEUR(SI(plagelibelAN=$F$11;LIGNE(plagelibelAN)-1);LIGNES($1:1)));SIERREUR(INDEX(O$2:O$99;PETITE.VALEUR(SI(plagedebAN=$F$11;LIGNE(plagedebAN)-1);LIGNES($1:1)));INDEX(O$2:O$99;PETITE.VALEUR(SI(plagecredAN=$F$11;LIGNE(plagecredAN)-1);LIGNES($1:1)))));"")

copier vers le bas et la droite

JHA
Merci pour la réponse, mais cela ne change pas.
 

Statistiques des forums

Discussions
313 296
Messages
2 096 912
Membres
106 786
dernier inscrit
Mgordat