position de travail vacante / planning

exene

XLDnaute Accro
Bonjour au forum et à ses contributeurs.
Je suis un nouvel inscrit. J'utilise un planning organisé en 4 onglets(trimestres) et alimenté par une table/matrice (travail cyclique). En ligne, il ya les jours, en colonne des noms et ensuite la position de travail tenue (ex : pt1). Le tableau est modifié en fonction des circonstances. Pous savoir si chaque jour toutes les positions de travail sont tenues, j'utilise la fonction NB.SI(plage; critère) et la mise forme conditionnelle. Si = 1 , position couverte, si = 0 position à découvert, si sup à 1, plusieurs agents affectées sur une même position . C'est assez fastidieux car il faut répéter la formule pour chaque position. Connaitriez vous un moyen plus rapide de faire cet "inventaire" journalier. Je suis allé dans les archives, à ma connaissance le sujet n'est pas abordé de cette façon.
PS : le tableau est assez rustique par rapport à ce que j'ai pu lire.
Merci.
 
Dernière édition:

gilbert_RGI

XLDnaute Barbatruc

jmd2

XLDnaute Accro
Re : position de travail vacante / planning

hello

ai-je compris que tu as disons 10 ou 20 postes chaque jour ?

alors crée autant de cases par jour (en ligne n° 45 ou autre)
case EU45 = NB.SI(plage; critère pt1)
case EV45 = NB.SI(plage; critère pt2)
case EW45 = NB.SI(plage; critère pt3)

tu crées ces formules une fois por toutes,et ça devrait rouler
 

Monique

Nous a quitté
Repose en paix
Re : position de travail vacante / planning

Bonjour,

Si on prend un n° comme départ (le nème horaire), on recommence tout l'année prochaine.
Début = date à laquelle la 1ère personne de la liste a fait ou fera le 1er horaire du 1er cycle (cellule nommée "Deb")
Ce n'est pas forcément une date de l'année en cours

J'ai donc refait la formule donnant les postes de travail
C'est la même formule sur tout le tableau, que ce soit un dimanche, un férié ou un jour de semaine
Les dimanches et fériés, la formule renvoie "" (rien)
=SI(OU($A5="";NB.SI(Fer;D$4);JOURSEM(D$4)=1);"";INDEX(DECALER(Cyc;$A5;0);MOD(D$4-Deb+1;42)))

INDEX(DECALER(Cyc;$A5;0);MOD(D$4-Deb+1;42))
42 est la durée du cycle, dimanches inclus. Quand on arrive à 42, la formule repart à 1, 2, etc
MOD(D$4-Deb+1;42) renvoie le reste de la division par 42 de la différence entre la date de début et la date du jour (renvoie donc un nb entre 1 et 42)
DECALER(Cyc;$A5;0) donne la plage de chaque personne
INDEX(Plage ; n°) renvoie le poste de travail

Pour les postes en trop ou ceux qui manquent,
en bas de feuille, il y a le nombre, en plus ou en moins,
et la liste des postes en trop et celle des postes qui manquent
Formule matricielle, à valider par ctrl, maj et entrée

Il y a quelque chose d'un peu semblable ici (le fichier d'hier à 17h44) :
https://www.excel-downloads.com/threads/planning-et-cycle.93897/
 

Pièces jointes

  • PlanningExene.zip
    45.3 KB · Affichages: 146
  • PlanningExene.zip
    45.3 KB · Affichages: 157
  • PlanningExene.zip
    45.3 KB · Affichages: 147

exene

XLDnaute Accro
Re : position de travail vacante / planning

Bonsoir,
Oups !. Merci !
Ce tableau représantait la limite de mes compétences. Je vais devoir me pencher sur les formules que tu as ajoutée pour comprendre leur "fonctionnement". J'avais lu le sujet posté que tu mentionne, effectivement cela est très ressemblant, la fonction hospitalière semble avoir également le même genre de soucis.
Cordialement
 

Statistiques des forums

Discussions
312 084
Messages
2 085 194
Membres
102 813
dernier inscrit
kaiyi