numérotation croissante automatique après filtre

ripo

XLDnaute Junior
Bonsoir à tous,
Je cherche la solution pour numéroter par ordre croissant les lignes qui 'restent' après filtrage automatique

...ci joint, matrice pour exemple

Merci,
a
A+
Ripo [file name=Classeur1_20051104212344.zip size=4088]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Classeur1_20051104212344.zip[/file]
 

Pièces jointes

  • Classeur1_20051104212344.zip
    4 KB · Affichages: 207

Jocelyn

XLDnaute Barbatruc
Bonsoir le Forum,
Bonsoir Ripo,

je ne suis poas sur d'avoir compris ta demande mais tu peux essayé en D4 la formule

=ligne()-3 à recopier vers le bas

ligne() renvoi 4 et - 3 =1
sur la ligne d'aprés : ligne()=5 moins 3 = 2 etc ....

Jocelyn
 

ripo

XLDnaute Junior
Bonsoir le Forum,
Bonsoir Jocelyn,

Merci de ta réponse, mais je souhaite que la numérotation commence à 1 et numérote chaque lignes de façon croissante (1234567...)

Je joint un nouvel exemple, avec ta formule...
après le tri, ce n'est pas croissant
merci,
A+ [file name=Classeur1_20051104223041.zip size=3558]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Classeur1_20051104223041.zip[/file]

Message édité par: ripo, à: 04/11/2005 22:31
 

Pièces jointes

  • Classeur1_20051104223041.zip
    3.5 KB · Affichages: 240

Charly2

Nous a quittés en 2006
Repose en paix
Bonsoir ripo, Jocelyn, bonsoir le forum,

Si tu souhaites uniquement obtenir à numéroter les lignes qui restent 'après filtrage' sur la colonne B, tu peux essayer la formule suivante dans la colonne D (ORDRE) :

=NB.SI($B$4:B4;B4)

que tu recopies vers le bas.

Le résultat ne sera correct et croissant qu'après le filtrage de la colonne B.

Amicalement
Charly
 

ripo

XLDnaute Junior
Bonjour, le forum,
Bonjour, Charly2,JeanMarie,

Merci de votre aide...

Charly2, ta formule était OK si les valeurs de la colone étaient identiques (dans mon exemple, c'était le cas; mais pas en réalité... C'est mon exemple qui n'était pas terrible...:))

Jean marie, c'est parfait!, no comment!

merci à tous les deux
A+
Ripo
 

Statistiques des forums

Discussions
312 814
Messages
2 092 339
Membres
105 374
dernier inscrit
kjk