Microsoft 365 Nombre d'occurence et filtre actif

darkhomer

XLDnaute Nouveau
Bonjour à vous tous,
Je cherche une solution pour avoir, le nombre de présence d'un mot identique (mot issue d'une liste "Copieur, Ged, Informatique"...),
Cette demande marche avec la formule =(NB.SI(J3:J466;"copieur")) mais elle m'affiche le résultat de tout mon classeur
Elle ne change pas si je filtre une colonne !!!!
J'ai besoin d'avoir cette valeur lorsque que j'applique des filtres sur des colonnes

Pour des chiffres sur ce classeur c'est bon avec =SOUS.TOTAL(109;L3:L390)

Est ce possible d'associer ou concatèner ces 2 fonctions ?

Ou je dois utiliser une autre formule pour avoir le résultat voulu

Merci d'avance
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

A essayer
VB:
=SOMMEPROD((SOUS.TOTAL(3;DECALER(Tableau44[[STATUT  ]];LIGNE(Tableau44[[STATUT  ]])-MIN(LIGNE(Tableau44[[STATUT  ]]));;1)))*(Tableau44[Matériel]="copieur"))

JHA
 

Pièces jointes

  • Test Prev 2022.xlsx
    15.6 KB · Affichages: 0

darkhomer

XLDnaute Nouveau
Bonjour à tous,

A essayer
VB:
=SOMMEPROD((SOUS.TOTAL(3;DECALER(Tableau44[[STATUT  ]];LIGNE(Tableau44[[STATUT  ]])-MIN(LIGNE(Tableau44[[STATUT  ]]));;1)))*(Tableau44[Matériel]="copieur"))

JHA
Trop cool cela fonction exactement sur mon tableau final, Merci beaucoup. Juste une dernière question comment tu fait pour pour savoir le nom du tableau eavoir la valeur Tableau44[STATUT]
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

lorsque tu construis ta formule, après le signe "=", tu mets la souris sur la cellule "D5" lorsque le pointeur change en "flèche vers le bas", tu cliques sur la souris cela va mettre en surbrillance toute la colonne du tableau et mettre le chemin dans la formule.

JHA
 

Pièces jointes

  • Test Prev 2022 rev1.xlsx
    16.4 KB · Affichages: 2

JHA

XLDnaute Barbatruc
Bonjour à tous,

Je ne connais pas excel Mac mais il faut pointer avec la souris sur le haut de la cellule "D5", le curseur devrait changer de forme.

1641473704166.png


JHA
 

mapomme

XLDnaute Barbatruc
Supporter XLD
Bonjour à tous,

Pour simplifier les formules, on peut ajouter une colonne dans le tableau de titre "Filtré" et de formule =AGREGAT(3;5;[@Matériel])
  • si la ligne est masquée par le filtre alors la formule renvoie un 0
  • si la ligne est affichée alors la cellule renvoie 1 - sauf si la cellule de la colonne matériel est vide et dans ce cas elle renvoie 0
Les formules en I8 et K4 deviennent de simples SOMMEPROD:
=SOMMEPROD((Tableau44[Matériel]=H4)*Tableau44[Filtré])
=SOMMEPROD((Tableau44[Matériel]=J4)*Tableau44[Filtré])

On peut tester en filtrant sue la colonne STATUR par exemple.
 

Pièces jointes

  • darkhomer- Test Prev 2022- v1.xlsx
    16.4 KB · Affichages: 7

darkhomer

XLDnaute Nouveau
Bonjour à tous,

Pour simplifier les formules, on peut ajouter une colonne dans le tableau de titre "Filtré" et de formule =AGREGAT(3;5;[@Matériel])
  • si la ligne est masquée par le filtre alors la formule renvoie un 0
  • si la ligne est affichée alors la cellule renvoie 1 - sauf si la cellule de la colonne matériel est vide et dans ce cas elle renvoie 0
Les formules en I8 et K4 deviennent de simples SOMMEPROD:
=SOMMEPROD((Tableau44[Matériel]=H4)*Tableau44[Filtré])
=SOMMEPROD((Tableau44[Matériel]=J4)*Tableau44[Filtré])

On peut tester en filtrant sue la colonne STATUR par exemple.
Sur le tableau final en pièces jointes, le calcule fonctionne à moitié ? il ne me remonte pas tout les mots ged ? dans le tableau global qui est un résumé en requêtes des 4 premiers tableau ?
lorsque des modification sont apporter par 1 des 4 commerciaux, je dois effacer le tableau global et l'actualiser ensuite, ce qui en soit n'ai pas trop dérangent car il a pour vocation d'être traiter par le responsable commercial qu'une 1 fois pas semaine, ce qui est bizarre c'est que lors de l'actualisation il me remonte énormément de ligne vierge en plus ?
 

Pièces jointes

  • Original-PREV-12-21 GLOBAL copie.xlsx
    112.4 KB · Affichages: 4

darkhomer

XLDnaute Nouveau
Bonjour à tous,

Pour simplifier les formules, on peut ajouter une colonne dans le tableau de titre "Filtré" et de formule =AGREGAT(3;5;[@Matériel])
  • si la ligne est masquée par le filtre alors la formule renvoie un 0
  • si la ligne est affichée alors la cellule renvoie 1 - sauf si la cellule de la colonne matériel est vide et dans ce cas elle renvoie 0
Les formules en I8 et K4 deviennent de simples SOMMEPROD:
=SOMMEPROD((Tableau44[Matériel]=H4)*Tableau44[Filtré])
=SOMMEPROD((Tableau44[Matériel]=J4)*Tableau44[Filtré])

On peut tester en filtrant sue la colonne STATUR par exemple.
Cool, j'ai intégré ta dernière formule magique et le filtre et c'est OK, pour la flèche descendante sur Mac c'est OK aussi, il faut juste êtres précis avec la souris
Bonjour à tous,

Je ne sais pas comment tu as construit ta requête.
J'ai donc refait une requête sous Power Query (onglet RECAP)

JHA
Dsl je ne vois pas l'onglet récup,
ce que je souhait faire simplement au départ c'est de donner un accès à chaque commercial soit à un onglet ou un tableau personnel pour qu'il traite et renseigne son activité commercial et avoir un tableau de synthèse pour le responsable commercial qui reprend tous les chiffres cumulée ces commerciaux, si tu as une solution plus simple que le tableau existant je suis preneur, la requête existante n'a pas été réaliser par moi mais par l'ancien responsable qui est parti sans me donné la structure de sa requête..., j'arrive à intergrpéer les formule mais je découvre le monde des requêtes et Power Query
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

L'onglet "Recap" est de couleur rouge. Je pense que tu as pris la meilleure solution avec Power Query.

Je ne suis pas un spécialiste de Power Query non plus mais patience, il y a des grosses pointures sur ce site.

Pour la requête, j'ai mis les 4 onglets de suivi en mode connexion puis combiner ces 4 onglets dans une requête "Recap".

Après modification sur les onglets de suivi, il faut actualiser le tableau Recap.

JHA
 

darkhomer

XLDnaute Nouveau
Bonjour à tous,

Je ne sais pas comment tu as construit ta requête.
J'ai donc refait une requête sous Power Query (onglet RECAP)

JHA
Yes ton fichier avec l'onglet recepa est top et marche mieux que le global, question par contre la case D5 ne se remplit pas ! sur l'onglet Maxime et christophe il est vide et quand je le renseigner le fichier Excel m'indique une erreur que je ne peux modifier. De plus les infos de statut ne remonte pas toutes dans l'onglet récap exemple pour Morgane ?
 

Statistiques des forums

Discussions
304 878
Messages
2 022 700
Membres
222 991
dernier inscrit
ExpertDJ