nb.jours.ouvres / networkdays et zones nommées

F

Fredp757

Guest
Bonjour,

Chti'te question sur ce qu'accepte cette fonction :

exemple :

_date A_!__date B____!_resultat J360__!__resultat nb.jours.feries
________!__________!_______________!_______________________
A1______!___B1_____!____J1________!___R1__________________
A2______!___B2_____!____J2________!___R2__________________
A3______!___B3_____!____J3________!___R3__________________

de A1:A3, zone appelée ZONEA
de B1:B3, zone appelée ZONEB

si je fais en R1:R3 JOURS360(ZONEA;ZONEB), ca marche
si je fais en R1:R3 nb.jours.ouvres(ZONEA;ZONEB), c'est #VALEUR

Quelqu'un connait ?

Merci,
Fred.
 
N

nono

Guest
salut Fredp757, le forum

bin moi je ne connais pas la formule nb.jours.ouvres et si je ne m'abuse, elle n'existe pas alors forcement, ça va marcher beaucoup moi bien...

bon bin regarde le fichier joint, je t'ai fais une petit macro qui fonctionne !

A+
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Chez moi, ça ne marche pas.
Celles-ci non plus :
=FIN.MOIS(ZoneA;0)
=NO.SEMAINE(ZoneA;ZoneB)
=ALEA.ENTRE.BORNES(ZoneA;ZoneB)
=SERIE.JOUR.OUVRE(ZoneA;2)
Celles de l'utilitaire d'analyse ?

Celle-ci fonctionne :
=DATE(ANNEE(ZoneA);MOIS(ZoneA)+1;0)
 

chris

XLDnaute Barbatruc
Bonjour
en fait cela marche si on définit les nom de la façon suivante (1ere date en ligne 2 colonne A)
zoneA : =Feuil1!$A2:$A2
zoneB : =Feuil1!$B2:$B2
en étant placé sur la ligne 2 lors de la définition.

Ainsi la référence se décale à chaque ligne.
 
F

Fredp757

Guest
Hello a tous.

en fait, placer les zones comme suit :
zoneA : =Feuil1!$A2:$A2
zoneB : =Feuil1!$B2:$B2
revient a travailler cellule par cellule, alors que je tiens a travailler sur des zones,

J'ai creusé sur le message de Monique
=DATE(ANNEE(ZoneA);MOIS(ZoneA)+1;0)
et apres moulte tripatouillages, j'ai quelque chose, au final, ca donne :

=SI(CommitExist='Yes';NETWORKDAYS(DATE(ANNEE(_DateCreation);MOIS(_DateCreation);JOUR(_DateCreation));DATE(ANNEE(_DateAffectation);MOIS(_DateAffectation);JOUR(_DateAffectation)));'-')

Une cellule de fou, repetee a chaque ligne...

J'ai bien essayé de mettre ca en fonction 'flottante', mais ca gauffre.

Semblerait que ce soit la facon dont les dates sont entrees qui plante la fonction networkdays...

Merci pour votre aide
Fred.
 

chris

XLDnaute Barbatruc
Bonjour
Si ton calcul se fait bien ligne à ligne, un définition de zone flottante comme je l'ai indiqué fonctionne : cela donne le même fonctionnement que si on demande à Excel d'utiliser les en-tête de colonne comme identifiant de la colonne entière et non pas une définition de zone limitée à une ligne comme tu sembles le conclure.
AS-tu essayé ?
 

Statistiques des forums

Discussions
300 890
Messages
1 988 179
Membres
210 097
dernier inscrit
Leboucanier