Moyenne flottante en fonction de conditions

erch29

XLDnaute Nouveau
Bonjour,
Je souhaite faire une moyenne sur 5 valeurs (exemple colonne C). La moyenne doit commencer pour la première valeur supérieure à 1. Le dernier calcul doit être fait sur 5 valeurs (sur la valeur maximum et les 4 précédentes). Dès que la valeur max est passée, il ne doit pas y avoir de calcul de moyenne. J'ai mis l'exemple mais je souhaite faire cela automatiquement.

Merci pour vos réponses
 

Pièces jointes

  • Calcul moyenne.xlsx
    52.3 KB · Affichages: 5

gbinforme

XLDnaute Impliqué
Bonjour, Avec cette formule tu devrais avoir ton résultat recherché :
VB:
=MOYENNE(DECALER($C$1;EQUIV(MAX(C:C);$C:$C;0)-5;0;5;1))

Sur ton fichier l'on fait la moyenne de ces cellules ce qui donne 33,52
33,5​
33,52​
33,52​
33,52​
33,54
 

Discussions similaires

Statistiques des forums

Discussions
313 198
Messages
2 096 137
Membres
106 504
dernier inscrit
Kannankin Maxime