Microsoft 365 Moyenne de taux d'occupation

lolo_excelbeginner

XLDnaute Nouveau
Bonjour à tous,

J'ai un classeur Excel (une extraction) comportant 3 colonnes : La date et l'heure, un nombre, et un taux d'occupation.
J'aimerais savoir s'il était possible de traiter ces données de la manière suivante :
Obtenir un classeur avec en ligne les jours (1 jour = 1 ligne), et en colonne : des tranches horaires de 2h (00-2h, 2h-4h, 4h-6h, 6h-8h,...).
Et ce classeur serait rempli par les moyennes des données du classeur extrait.
Exemple : Données : 01/01/2023 00h 45%, 01/01/2023 00h10 49%, 01/01/2023 01h15 36%, 02/01/2023 69%)

Classeur final :

01/01/2023 | 00-2h = Moyenne(45%,49%,36%) | 2h-4h = Moyenne(........) | 4-6h |....
02/01/2023 |
03/03/2023 |

Pour l'instant je souhaiterais ce traitement uniquement pour la 3ème colonne (le %).

Je pense que vous comprendrez aisément mon besoin lorsque vous verrez la quantité de données à traiter dans la pièce jointe.

Je remercie par avance tous ceux qui prendront le temps d'essayer de répondre à ma demande.

Cordialement,

LOLO
 

Pièces jointes

  • Janvier-Mars 2023.xlsx
    305.5 KB · Affichages: 8
Solution
Bonjour lolo_excelbeginner,
Pas sur d'avoir tout compris.
Un essai en PJ par tranche horaires, et MFC avec :
VB:
=SIERREUR(MOYENNE.SI.ENS('Avenue Marx Dormoy'!$C:$C;'Avenue Marx Dormoy'!$A:$A;">="&($A2+B$1);'Avenue Marx Dormoy'!$A:$A;"<"&$A2+C$1);"")

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour lolo_excelbeginner,
Pas sur d'avoir tout compris.
Un essai en PJ par tranche horaires, et MFC avec :
VB:
=SIERREUR(MOYENNE.SI.ENS('Avenue Marx Dormoy'!$C:$C;'Avenue Marx Dormoy'!$A:$A;">="&($A2+B$1);'Avenue Marx Dormoy'!$A:$A;"<"&$A2+C$1);"")
 

Pièces jointes

  • Janvier-Mars 2023.xlsx
    329.6 KB · Affichages: 7

lolo_excelbeginner

XLDnaute Nouveau
Bonjour lolo_excelbeginner,
Pas sur d'avoir tout compris.
Un essai en PJ par tranche horaires, et MFC avec :
VB:
=SIERREUR(MOYENNE.SI.ENS('Avenue Marx Dormoy'!$C:$C;'Avenue Marx Dormoy'!$A:$A;">="&($A2+B$1);'Avenue Marx Dormoy'!$A:$A;"<"&$A2+C$1);"")
Bonjour Sylvanu,

C'est parfait merci beaucoup !! DSL d'avoir été un peu flou sur la demande.

Je ne connaissais pas la fonction MOYENNE.SI.ENS, belle découverte, merci beaucoup !

CDT

LOLO
 

Discussions similaires

Statistiques des forums

Discussions
313 259
Messages
2 096 615
Membres
106 687
dernier inscrit
jessicabornet