Autres mention #VALEUR! en 0 pour sommeprod d'une autre cellule.

jdrc

XLDnaute Nouveau
bonsoir,
excel 2003
si année bissextile, est-il possible d'afficher 0 sur la cellule qui mentionne #VALEUR! afin qu'elle soit prise en compte pour la sommeprod d'autres cellules. la cellule problématique contient déjà une formule =SI(ET(ESTNA(RECHERCHEV(AD51;$BE$7:$BE$19;1;FAUX));JOURSEM(AD51;2)<6);NB.SI(AD52:AD85;"A 10");0
j'ai crée une déco de noêl avec des #VALEUR! merci de votre aide
 

Pièces jointes

  • cellule valeur1.jpg
    cellule valeur1.jpg
    94.5 KB · Affichages: 9

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir Jdrc,
Pouvez vous me dire en quoi votre image illustre vos propos ?
Vous n'auriez pas un petit fichier test plutôt.
Si c'est juste pour mettre 0 à la place de #Valeur, faites :
VB:
=SIERREUR(SI(ET(ESTNA(RECHERCHEV(AD51;$BE$7:$BE$19;1;FAUX));JOURSEM(AD51;2)<6);NB.SI(AD52:AD85;"A 10");0);0)
 

sylvanu

XLDnaute Barbatruc
Supporter XLD
Précisez dans votre profil XL2003 au lieu de autres, cela évitera ce genre de désagrément.
Essayez alors :
VB:
=SI(ESTERR(SI(ET(ESTNA(RECHERCHEV(AD51;$BE$7:$BE$19;1;FAUX));JOURSEM(AD51;2)<6);NB.SI(AD52:AD85;"A 10");0));0;SI(ET(ESTNA(RECHERCHEV(AD51;$BE$7:$BE$19;1;FAUX));JOURSEM(AD51;2)<6);NB.SI(AD52:AD85;"A 10");0))
 

Statistiques des forums

Discussions
313 317
Messages
2 097 114
Membres
106 843
dernier inscrit
wilfrid.hotome@qwamplify.