les zero me gene!

J

joJO

Guest
bonjour à tous

toujours autant de mal avec les valeurs négative !j espere trouvé quelqu un qui puisse m aider
merci
joJO [file name=ZERO.zip size=2807]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/ZERO.zip[/file]
 

Pièces jointes

  • ZERO.zip
    3.2 KB · Affichages: 10
  • ZERO.zip
    3.2 KB · Affichages: 11
  • ZERO.zip
    3.2 KB · Affichages: 12

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour Jojo,

bon pour la premiere partie qui est de faire apparaitre en 0 en B7 si A7 =0 tu peux essayer la formule :

=SI(A7=0;0;1*100/(A7+1)) que tu étires sur la colonne B

par contre le -7 que tu veux voir en D7 c'est le résultat de quoi. la je n'ai pas compris ta demande.

Jocelyn
 
J

joJO

Guest
c est encore moi

dans 5 colonnes j ai des ciffres

5 1 3 4 8 ( 5+1+3 ) = 9

dans la premiere je voudrais conserver les no de 1 a 5
ensuite ds les autres seulement de 1 a 3
pour me donner en fait la colonne A de mon tableau !
c est possible ?
jojo
 

Jocelyn

XLDnaute Barbatruc
re

tu peux me faire passer un fichier chiffré avec les explication parce que la c'est pas clair ou alors je suis vraiment dans le brouillard aujourd'hui.

tu ecris

5 1 3 4 8 pour les 5 colonnes et aprés ( 5+1+3 ) = 9 cette partie va ou et pourquoi une addition des 3 premiere cellule seulement

que veux tu dire dans la premiere je veux concervé les numéro de 1 a 5

et dans les autre de 1 a 3

autre élément les chiffres de ces colonne sont t'il calcule ou saisis directement

bon je vais prendre une aspirine en attendant ta réponse :) :)

Jocelyn

en relisant est ce que conserver voulais dire pour toi quand on fait l'addition des 5 cellulles on ne prend dans l'addition la cellulle 1que si elle est inférieur ou égale a 5 et les 4 autres que si elle sont inférieures ou égal a 3

Message édité par: jocelyn, à: 29/09/2005 15:10
 
J

jojo

Guest
non je veux pas te rendre malade

en fait j essaye d aditioner que les no inferieur a 6
avec cette formules mais il doit me manquer quelques chose
=sum(if(A1<6;A1;0);if(B1<6;b1;0)) ceci sur 5 colonnes
merci et excuse moi
 

Jocelyn

XLDnaute Barbatruc
re,

bon alors je te renvoi ton fichier avec les explications.

je t'ai fait 2 formules une avec toutes les colonnes inférieur ou égal à 6
l'autre colonne 1 inférieur ou égal a 5 et de 2 a 5 inférieur ou egal a 3 comme ta demande initiale

dis moi si c'est bon.

Jocelyn [file name=zero.zip size=3318]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/zero.zip[/file]
 

Pièces jointes

  • zero.zip
    3.2 KB · Affichages: 6
  • zero.zip
    3.2 KB · Affichages: 9
  • zero.zip
    3.2 KB · Affichages: 6

andré

XLDnaute Barbatruc
Salut Jocelyn et les autres,

Un tout petit raccourci de la première partie de la formule en F7 et une variante pour la deuxième partie, au cas où ... (mais à mon avis, tu as simplement oublié que cela existait) :

=SOMME.SI(A7;'<=5';A7)+SOMME.SI((B7:E7;'<=3';B7:E7)
=(A7<=5')*A7+SOMMEPROD(B7:E7<=3)*B7:E7)

Comme ce sont des nombres entiers, on pourrait même remplacer <=5 par <6, idem pour le 3.

Bonne soirée.
Â+
 

Discussions similaires

M
Réponses
0
Affichages
6 K
M
V
Réponses
3
Affichages
1 K
E
Réponses
3
Affichages
1 K
etudiant72
E
Réponses
5
Affichages
4 K
P
J
  • Question
Réponses
3
Affichages
1 K
jhonny
J

Membres actuellement en ligne

Statistiques des forums

Discussions
312 932
Messages
2 093 733
Membres
105 802
dernier inscrit
Witchun