XL 2016 Les formats de cellule ne s'affichent pas

catdog

XLDnaute Junior
Bonjour à tous,

C'est la seconde fois que je rencontre un problème étrange : dans une zone de tableau, Excel "refuse" de modifier le format.

Dans la pièce jointe, vous verrez que la cellule D78 devrait afficher une date, mais rien y fait. On reste en standard. De même, j'ai volontairement mis la position centrée horizontalement, et l'affichage reste à gauche.

Quelqu'un a-t-il une idée à ce comportement ?

Initialement, le document était en XLS. Je l'ai transformé en XLSX, sans résultat. Il s'agit d'une zone de tableau.

J'ai rencontré cette situation il y a peu dans un document, mais j'avais pris l'option on dézingue tout pour refaire... Mais j'avoue que là, c'est un document qu'on m'a envoyé, et je ne vois pas d'où vient le problème.

Merci d'avance pour vos retours,

Olivier

1648545132366.png
 
Solution
Bonjour Catdog, JHA, staple1600, le forum

@catdog , allez dans les options avancées/options d'affichage de la feuille de calcul pour la feuille Fournitures.
Décochez "Formules dans les cellules au lieu de leurs résultats calculés"
Et cela ira tout de suite mieux ! :oops: ;) 🤣

(ou menu formules et décochez "Afficher les formules", c'est plus rapide)

Cordialement, @+
[édition, il y aura un peu de mise en page à refaire ! :rolleyes: ]
1648568071737.png

catdog

XLDnaute Junior
Petit complément : l'alignement bloqué à gauche ne concerne que les valeurs numériques.
Comme il s'agit d'un fichier partagé par plusieurs utilisateurs, certains y saisissent aussi du texte...
Et même si revient à une plage de cellules classique, rien n'y fait.
Effacer les formats reste sans effet.

Je reste bloqué sur ce mystère...
 

catdog

XLDnaute Junior
Bonjour à tous,

Valeur à gauche, c'est certainement du texte.

Peux-tu joindre un petit fichier excel

JHA
Merci pour cette option... Hélas, j'y ai déjà songé... et ce n'est pas le cas.
Quand bien même ce serait du texte, si je demandais un alignement centré, cela se verrait...
J'ai converti les données en standard dans les deux colonnes concernées, rien y fait !

A n'y rien comprendre...

Il y a peu, j'ai eu un souci équivalent sur un document que je n'avais pas construit moi-même : l'affichage d'un montant était "bloqué" en € avec un affichage à gauche (ce que je n'aime pas en temps normal)...

Là, mystère complet...

Je joins le fichier en pièce jointe... même si je l'ai déjà pas mal trituré... Je mets le fichier en xls aussi... l'original...
 
Dernière modification par un modérateur:

Bernard_XLD

XLDnaute Barbatruc
Membre du Staff
Bonjour Catdog, JHA, staple1600, le forum

@catdog , allez dans les options avancées/options d'affichage de la feuille de calcul pour la feuille Fournitures.
Décochez "Formules dans les cellules au lieu de leurs résultats calculés"
Et cela ira tout de suite mieux ! :oops: ;) 🤣

(ou menu formules et décochez "Afficher les formules", c'est plus rapide)

Cordialement, @+
[édition, il y aura un peu de mise en page à refaire ! :rolleyes: ]
1648568071737.png
 
Dernière édition:

catdog

XLDnaute Junior
Bonjour Catdog, JHA, staple1600, le forum

@catdog , allez dans les options avancées/options d'affichage de la feuille de calcul pour la feuille Fournitures.
Décochez "Formules dans les cellules au lieu de leurs résultats calculés"
Et cela ira tout de suite mieux ! :oops: ;) 🤣

(ou menu formules et décochez "Afficher les formules", c'est plus rapide)

Cordialement, @+
[édition, il y aura un peu de mise en page à refaire ! :rolleyes: ]
Regarde la pièce jointe 1135245
Pétard, j'y suis allé, mais sans le voir...

Merci pour la découverte de l'impact de cette coche...