Help! associer valeurs à txt sous menus déroulant

raphhg

XLDnaute Nouveau
Bonsoir,
J'utilise peu excel sous ces questions de macro... et là je sèche; après plusieurs heures de recherche...
Ma demande me paraissait simple, mais pas tant que ca peut-être.
J'ai deux colonnes avec menus déroulant txt. je souhaite associer des valeurs numéraires simple pour combiner ensuite les facteurs dans une troisième colonne.
Une première colonne 3 critères txt que j'associe donc à 4-3-2
Une deuxieme colonne 4 critères txt que j'associe ainsi 4-3-2-1
Ma dernière colonne est l'addition des deux.
Je glisse en PJ mon fichier, en espérant que quelqu'un ait la gentillesse et le temps de m'aider....

Merci pour votre lecture
Raphhg
 

Pièces jointes

  • 2018-EnquêteI-serrures.xlsx
    13.1 KB · Affichages: 20

Dranreb

XLDnaute Barbatruc
Bonsoir.
Cette formule additionnerait les valeurs associées aux deux critères :
Code:
=INDEX(Feuil2!$B$1:$B$3;EQUIV($D4;Feuil2!$A$1:$A$3;0))+INDEX(Feuil2!$E$1:$E4;EQUIV($E4;Feuil2!$C$1:$C4;0))
(À mettre dans une colonne non gênée par une validation ni un format de texte et en ligne 4, à propager au nombre de lignes voulu)
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour raphhg, Dranreb ;),

Principalement pour saluer Dranreb et pour apporter une autre solution moi j'aurais plutôt utilisé cette formule

Code:
=SOMMEPROD((Feuil2!A$1:A$4=D3)*Feuil2!$B$1:$B$4+((Feuil2!$C$1:$C$4=E3)*Feuil2!$E$1:$E$4))

pour éviter les valeurs d'erreurs au cas ou une seule des colonnes D et E serait remplie

Voir fichier

Cordialement
 

Pièces jointes

  • 2018-EnquêteI-serrures.xlsx
    14 KB · Affichages: 20

Statistiques des forums

Discussions
312 961
Messages
2 093 958
Membres
105 899
dernier inscrit
rolltchic