Formules automatique

E

Excel

Guest
Bonjour,
Avec Excel 2000, j'ai fait un tableau par année, dans lequel j'ai tous les mois de l'année.
Je voudrais qu'une somme'Exp 250' se mette automatiquement le 30 de chaque mois dans une cellule.
par exemple :
Janvier 250 (le 30 du mois)
Février 250 (le 30 du mois)
Mars 250 (le 30 du mois) etc....
Est-ce que quelqu'un connait la formule.
Merci de votre aide.
 

andré

XLDnaute Barbatruc
Salut,

J'ai du mal à comprendre la portée exate de ta demande.

Mettre une formule automatiquement dans une cellule à une date donnée, il n'y a pas moyen, si ce n'est par macro.

Mais que la formule ne donne le résultat que le 30 du mois, là oui.

Si tu mettais un petit extrait de ton fichier en pièce jointe, ce serait plus facile pour te donner une réponse circonstanciée.

Â+
 
D

Dominique

Guest
Excel écrit:
Bonjour,
Avec Excel 2000, j'ai fait un tableau par année, dans lequel j'ai tous les mois de l'année.
Je voudrais qu'une somme'Exp 250' se mette automatiquement le 30 de chaque mois dans une cellule.
par exemple :
Janvier 250 (le 30 du mois)
Février 250 (le 30 du mois)
Mars 250 (le 30 du mois) etc....
Est-ce que quelqu'un connait la formule.
Merci de votre aide.
 

andré

XLDnaute Barbatruc
Salut hononyme,

Essaie ceci, mais c'est un peu à l'aveuglette :

=SI(JOUR(AUJOURDHUI())=30;SOMME(....);'')

Mais cette formule ne t'affichera le résultat que le 30 de chaque mois, ni la veille, ni le lendemain.
Avec un sérieux problème pour le mois de février !

Mais je crois que ce n'est pas ce que tu veux.
Ne serait-ce pas 'à partir du 30 du mois concerné, sauf pour le mois de février où c'est le dernier jour du mois' ?

Tout cela est possible.
Mais avec un petit exemple ce serait beaucoup plus facile.

Â+

Message édité par: andré, à: 02/11/2005 17:37
 
C

Claude

Guest
Bonjour Guerry,André,

Comme André je suis perplexe pour février qu'elle date utilisée?
En attendant une façon avec inscription à la date de fin de mois le 30 ou 31 pour chaque mois, et le 28 ou 29 février pour les années bissextiles.
Une autre avec inscription la veille de la date de fin de mois.
Un exemple de ton tableau serait bienvenu.
Bonne journée [file name=sommeauto.zip size=7234]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/sommeauto.zip[/file]
 

Pièces jointes

  • sommeauto.zip
    7.1 KB · Affichages: 26

andré

XLDnaute Barbatruc
Salut Claude,

Pour récupérer la date du 30 de chaque mois, sauf pour le mois de février où ce doit être le dernier jour (28 ou 29 suivant le cas), la formule suivante le fait :

En A1 : la date
En A2 : =MIN(FIN.MOIS(A1;0);DATE(ANNEE(A1);MOIS(A1);30))

Â+
 
A

andré

Guest
Salut JeanMarie,

Excuse-moi de te contredire, mais ta formule renvoie le dernier jour du mois.

Il était demandé de renvoyer le dernier jour pour le mois de février et le 30 pour les autres mois.

Ce qui donne la fomule :
=SI(JOUR(AUJOURDHUI())=MIN(FIN.MOIS(AUJOURDHUI();0);DATE(ANNEE(AUJOURDHUI());MOIS(AUJOURDHUI());30));250;'')

Â+
 
C

Claude

Guest
Re,

Merci André pour ta formule
Je l'ai adapté à mes présentations

Bonne soirée [file name=sommeauto1.zip size=7198]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/sommeauto1.zip[/file]
 

Pièces jointes

  • sommeauto1.zip
    7 KB · Affichages: 25

Discussions similaires

Réponses
16
Affichages
839

Membres actuellement en ligne

Statistiques des forums

Discussions
312 816
Messages
2 092 361
Membres
105 378
dernier inscrit
y07