Formule SI() à plusieurs conditions! Completement bloqué!

Jeydu77410

XLDnaute Nouveau
Bonjour à tous.

Voila, je me creuse la tête depuis plusieurs jours et j'ai vraiment besoin d'aide!

Je suis à la recherche d'une formule qui combine plusieurs élement à savoir les fonctions SI, OU, et ET... je vais essayer de m'expliquer.

Voila sur mon fichier Excel j'ai plusieurs éléments :

Un montant en L5
Un département de livraison rempli par le client en K41

Voila ce que je souhaiterai...

SI le département saisie est 77 OU 78 OU 91 OU 92 OU 93 OU 94 OU 95 OU 75ET le montant est > ou = à 1000€ , ALORS résultat = 0€ sinon 50€

Pour cette première partie, j'ai réussi à créer la formule ci-dessus:

=SI(OU(L43=77;L43=78;L43=91;L43=92;L43=93;L43=94;L43=75)*(ET(L5>=1000));"0€00";"50€00")

MAIS CE N'EST PAS VRAIMENT CE QUE JE VEUX!!! :D

A cette formule je veux ajouté cela :

SI département est différent du 77, OU 78, OU 91, OU 92, OU 93, OU 94, OU 95, OU 75 ET le montant est > ou = à 1500€ ALORS résultat = 0€ sinon 80€


Je ne sais pas comment intégrer cela à la formule si dessus...

SVP j'ai vraiment besoin de cette formule.

Merci d'avance.
 

ROGER2327

XLDnaute Barbatruc
Re : Formule SI() à plusieurs conditions! Completement bloqué!

Bonjour Jeydu77410
Peut-être ceci :
Code:
[B][COLOR="DarkSlateGray"]=SI(OU(L43=77;L43=78;L43=91;L43=92;L43=93;L43=94;L43=75);SI(L5>=1000;0;50);SI(L5>=1500;0;80))[/COLOR][/B]
ROGER2327
#4295


Samedi 7 Haha 138 (Saint Prout, abbé, SQ)
21 Vendémiaire An CCXIX
2010-W41-2T23:54:04Z
 

hoerwind

XLDnaute Barbatruc
Re : Formule SI() à plusieurs conditions! Completement bloqué!

Bonjour et bienvenu sur le forum, salut Roger et kjin,

J'ai testé les deux formules proposées, mais aucune d'entre elles ne renvoie le même résultat que celle-ci :
=OU(L43={77;78;91;92;93;94;75})*((L5>=1000)*50+(L5>=1500)*30)

A tester avec L43 et/ou L5 vides.
 

ROGER2327

XLDnaute Barbatruc
Re : Formule SI() à plusieurs conditions! Completement bloqué!

Bonjour à tous, bonjour hoerwind
Bonjour et bienvenu sur le forum, salut Roger et kjin,

J'ai testé les deux formules proposées, mais aucune d'entre elles ne renvoie le même résultat que celle-ci :
=OU(L43={77;78;91;92;93;94;75})*((L5>=1000)*50+(L5>=1500)*30)

A tester avec L43 et/ou L5 vides.
Certes. On peut imaginer une foultitude de formules qui ne donne pas le même résultat que
Code:
[COLOR="DarkSlateGray"][B]=OU(L43={77;78;91;92;93;94;75})*((L5>=1000)*50+(L5>=1500)*30)[/B][/COLOR]
Où est le problème ?​
ROGER2327
#4299


Dimanche 8 Haha 138 (Fête du Haha, SS)
22 Vendémiaire An CCXIX
2010-W41-3T10:21:44Z
 

hoerwind

XLDnaute Barbatruc
Re : Formule SI() à plusieurs conditions! Completement bloqué!

Re,

Tu as raison Roger, ta formule est bonne, pas la mienne.
Je l'ai rectifiée sous la pièce jointe.
Celle de kjin semble présenter un petit problème dans certains cas.
 

Pièces jointes

  • ConditionsMultiples.xls
    17 KB · Affichages: 70
  • ConditionsMultiples.xls
    17 KB · Affichages: 78
  • ConditionsMultiples.xls
    17 KB · Affichages: 73

natorp

XLDnaute Accro
Re : Formule SI() à plusieurs conditions! Completement bloqué!

Bjr à tous

le problème de kjin vient de l'énoncé de Jey, il annonce les départements en K41 et en fait ils sont en L43 d'où "l'erreur" de kjin, si l'on remplace K41 par L43 dans la formule de kjin, vous obtenez tous les trois le même résultat ==>>> Bravo !!

cordialement, Gérard
 

ROGER2327

XLDnaute Barbatruc
Re : Formule SI() à plusieurs conditions! Completement bloqué!

Re...
Vu !
La formule de kjin fonctionne si on remplace K41 par L43.
Une amélioration possible pour toutes nos formules :
Code:
[COLOR="DarkSlateGray"]=[COLOR="Red"][B]SI((L5="")+(L43="");"";[/B][/COLOR]SI(OU(L43=77;L43=78;L43=91;L43=92;L43=93;L43=94;L43=75);SI(L5>=1000;0;50);SI(L5>=1500;0;80))[COLOR="Red"][B])[/B][/COLOR][/COLOR]
pour ne rien renvoyer si une des deux données est indisponible.​
ROGER2327
#4302


Dimanche 8 Haha 138 (Fête du Haha, SS)
22 Vendémiaire An CCXIX
2010-W41-3T13:22:32Z
 

Jeydu77410

XLDnaute Nouveau
Re : Formule SI() à plusieurs conditions! Completement bloqué!

Alors là! je tiens à dire que vous m'enlever une belle épine du pied!!!

Comme j'aimerai être capable de refaire cela moi même la prochaine fois, pourriez*vous m'expliquez deux trois chose que je n'ai pas compris dans les formules (je n'ai fait de formation j'essaye donc d'apprendre un peu plus quand je le peux :p):

Dans la formule de KJIN, il y a les formules ESTNA et EQUIV... je ne les connaissais pas...
De plus, pourriez vous me dire à quoi elles servent, et avec des mots que fait la formule c'est à dire par exemple : Si département = 77,78,... et L43 équivault à 1000 ....

Hoerwind apparemment ta formule marche aussi mais je ne comprend pas pourquoi tu commence avec une formule OU? et peut tu ossi me dire avec des mots ce que fait ta formule?

Roger j'ai pris ta formule... elle me paraissait la plus simple pour l'autodidact que je suis :eek: ... la modification à la fin est parfaite!!! rien ne s'affiche si L5 et L43 sont vides!!!

Merci à tous en espérant que vous aurez le temps de répondre à mes question.
 

Statistiques des forums

Discussions
299 914
Messages
1 980 042
Membres
206 963
dernier inscrit
julien183645