Fonction SI sur une plage de données

Excel_forum

XLDnaute Nouveau
Bonjour,

J'ai un tableau où sont entrés 5 mots associés à un thème par des individus qui ont été interrogés. Ces mots ont été entrés dans le tableau en ligne, un mot dans une colone distincte, comme ceci :

Sujet 1 Age Mot1 Mot2 Mot3 Mot4 Mot5
Sujet 2 Age Mot1 Mot2 Mot3 Mot4 Mot5
Sujet 3 Age Mot1 Mot2 Mot3 Mot4 Mot5
Sujet 4 Age Mot1 Mot2 Mot3 Mot4 Mot5
etc

J'ai catégorisé les mots en différents thèmes (puis remplacés les mots énoncés par leur thème), et je voudrais maintenant créer un tableau où j'aurais les thèmes énoncés par l'ensemble des individus interrogés en colone , et garder en ligne les sujets interrogés. Si les personnes ont parlé du thème figurant en colone, on trouve 1, sinon 0.

theme1 theme2 theme3 theme4 theme5 theme6 ......
Sujet 1 Age 1 0 0 0 1 0
Sujet 2 Age 0 1 1 1 1 1
Sujet 3 Age 0 0 1 1 1 1
Sujet 4 Age 0 0 0 0 1 0



J'avais pensé à utiliser une fonction SI, avec la formule :

=SI(A3:A7="nom du theme";1;0) puis "ctrl/Maj/Entrée" pour valider

A3:A7 serait la plage de cellule allant du 1er mot au 5ème mot pour le sujet 1.
Il y a parfois des cellules vides, si les personnes interrogées ne trouve que 3 ou 4 mots par exemple.

Cependant, cela ne me compte "1" que quand le thème est présent en cellule A3 ou A7, mais s'il a été cité en position intermediaire, cela me code 0.

J'avoue que je suis perplexe...
Quelqu'un aurait une solution à ce problème ?


Merci d'avance,
Cordialement.
 

Pièces jointes

  • Excel.jpg
    Excel.jpg
    107.9 KB · Affichages: 234
  • Excel.jpg
    Excel.jpg
    107.9 KB · Affichages: 282
  • Excel.jpg
    Excel.jpg
    107.9 KB · Affichages: 280

Discussions similaires

Réponses
14
Affichages
627

Membres actuellement en ligne

Statistiques des forums

Discussions
312 884
Messages
2 093 252
Membres
105 658
dernier inscrit
Mario Richard