Fonction décaler sur la cellule non vide suivante

ROM

XLDnaute Nouveau
Bonjour à tous,

J'ai une difficulté que je n'arrive pas à contourner et j'espère que vous pourrez m'aider. J'utilise une fonction décaler sur cellule non vide. J'ai réussi à décaler en fonction de la première cellule non vide mais je n'ai pas réussi à utiliser la fonction décaler en fonction de la deuxième cellule non vide.

Ci joint le fichier

Merci par avance pour votre aide.
 

Pièces jointes

  • fiche_aide.xlsx
    19.5 KB · Affichages: 272
Dernière édition:

R@chid

XLDnaute Barbatruc
Re : Fonction décaler sur la cellule non vide suivante

Bonsoir,
Demande n'est pas claire,
si j'ai bien compris, en Q6,
Code:
=SIERREUR(INDEX($B1:$O1;PETITE.VALEUR(SI($B6:$O6<>"";COLONNE($B1:$O1)-1);COLONNES($Q:Q)));"")
@ valider par Ctrl+Maj+Entree
@ tirer vers la droite
@ micalement

Edit :
Avec DECALER(),
Code:
=SIERREUR(DECALER($A1;;PETITE.VALEUR(SI($B6:$O6<>"";COLONNE($B1:$O1)-1);COLONNES($Q:Q)));"")
@ valider toujours par Ctrl+Maj+Entree
@ tirer vers la droite
@ micalement
 
Dernière édition:

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
312 922
Messages
2 093 643
Membres
105 773
dernier inscrit
godelvie-divine.bihonda-b