XL 2016 Filtrer codes postaux commençant par zéro

Paarm

XLDnaute Nouveau
Bonjour à tous,
Je souhaite transformer tous les codes postaux en département. Pour ce faire, j'ai utilisé la formule =Gauche(A1;2) pour récupérer les 2 1ers chiffres du code postal. Je vous joins le fichier.
Le souci est qu'Excel interprète les codes postaux sans le zéro. Les codes postaux qui commencent par 23 et ceux qui commencent par 02 restituent le même résultat, à savoir le dépt 23 parce que le zéro des codes postaux n'est pas pris en compte par Excel. J'espère que j'ai été explicite.

Merci de votre aide et bonne soirée,

CODE POSTALVILLEDépt
23140JARNAGES23
02390THENELLES23
02303CHAUNY23
23300LA SOUTERRAINE23
02300CHAUNY23
23290ST PIERRE DE FURSAC23
23200AUBUSSON23
 

Pièces jointes

  • Filtrer codes postaux commençant par zéro.xlsx
    10.6 KB · Affichages: 19
Solution
Bonsoir à tous,

Si vous voulez un résultat numérique (et non transformé en texte) la formule suivante doit suffire :
VB:
=ENT(A3/1000)

Sinon pour le fun, si vous voulez un résultat texte, une autre formule 😊:
VB:
=GAUCHE(DROITE("0"&A2;5);2)

D.D.

XLDnaute Impliqué
Hello

Le problème est que tes codes postaux (colonne A) sont entrés comme des chiffres et que la représentation est juste via une mise en forme.

Sinon tu peux faire:
=SI(A2<10000;"0"& GAUCHE(A2;1);GAUCHE(A2;2))
ou
=ARRONDI.INF(A2/1000;0)
 

GALOUGALOU

XLDnaute Accro
pour compléter l'information de roblochon
En France, le code postal d'une ville n'est pas lié à son département, mais au bureau distributeur de courrier à laquelle elle est rattachée. Par exemple, la commune de Laveyrune se trouve en Ardèche (07) mais son code postal est 48250, car elle est rattachée à un bureau distributeur situé en Lozère (48).
cordialement
galougalou
 

Statistiques des forums

Discussions
303 639
Messages
2 012 821
Membres
219 426
dernier inscrit
Koffi33