Faire une somme avec des cellules contenant du texte

Etoto

XLDnaute Barbatruc
Bonjour à tous,

J'ai créé une formule qui permet de faire des sommes avec des cellules contenant du texte, exemple :

Sn 48
2
ar 2

Résultat : 52

Je précise que le texte doit se situer avant le nombre et il doit être séparé par un espace (ou autre, il suffit de changer la variable du CHERCHE)

VB:
=SOMME(SIERREUR(CNUM(SUBSTITUE(B15:B21;GAUCHE(B15:B21;CHERCHE(" ";B15:B21));""));B15:B21))

Je précise que cette formule est matricielle, pour les non détenteurs d'Office 365, il faut la valider par Ctrl + Maj + Enter

Pensant que cette formule pourrait être utile pour certains membres, je l'ai postée ici. Bien sûr, je suppose que cette formule n'est pas la meilleure, vous pouvez toujours donner des améliorations sur ce fil.

Cordialement @+
 

Staple1600

XLDnaute Barbatruc
Bonjour Etoto

Ce n'est pas une amélioration, mais une variation
En A1, nous avons
abc 1 defg 499 hijk 821 LMN 279
En B1, nous saisissons
Enrichi (BBcode):
=CAR(83)&SOMMEPROD(FILTRE.XML("<t><s>"&SUBSTITUE(SUBSTITUE(A1;" ";"</s><s>");" ";"</s><s>")&"</s></t>";"//s[number()=.]"))
NB: C'est la partie marron de la formule qui nous intéresse ici
(Une fois le résultat affiché en B1, vous comprendrez pourquoi ;))

PS: Ne fonctionne qu'à partir d'Excel 2013.
 

Discussions similaires

Membres actuellement en ligne

Statistiques des forums

Discussions
312 827
Messages
2 092 555
Membres
105 451
dernier inscrit
mariane_lp