Extraire données suivant conditions

loost77

XLDnaute Nouveau
Bonjour,

J'ai un peu cherché avant de poster mais je ne trouve pas la bonne fonction pour faire ce que je veux.

Dans le fichier d'exemple (le vrai est bcp plus long), j'aimerais, dans une deuxième feuille, extraire les numéros et les mettre dans la colonne A et mettre en regard dans la colonne B le texte qui se trouve en dessous du numéro dans la feuille 1.

En gros trier la feuille pour pouvoir m'en servir dans un publipostage, avec dans une colonne les codes économiques et dans l'autre le libellé correspondant alors que pour le moment le libellé se trouve en dessous du code, en sachant que l'écart entre les cellules varient parfois.

Si vous m'avez compris, vous êtes déjà fort !

Merci d'avance.
 

Pièces jointes

  • test1.xls
    22 KB · Affichages: 74
  • test1.xls
    22 KB · Affichages: 77
  • test1.xls
    22 KB · Affichages: 74

GIBI

XLDnaute Impliqué
Re : Extraire données suivant conditions

Bonjour,

On peut ventiler d'une façon simple la colonne a en deux colonnes :

le numéro qui commence par une valeur numérique (ici je ne teste que 2 car numérique) le supprespace permet d'éliminer les blancs devant et derrière
=SI(ESTERREUR(CNUM(STXT(SUPPRESPACE(A1);1;2)));"";A1)
le libellé qui ne commence par du numérique
=SI(ESTERREUR(CNUM(STXT(SUPPRESPACE(A1);1;2)));"";A1)

1. on filtre la colonne a pour éliminer les lignes blanches
2. On écrit les formules
3. On duplique les formules

et voila, c'est basique mais çela fonctionne


Un peu de refexion et c'est fait

GIBI
 

ant75

XLDnaute Junior
Re : Extraire données suivant conditions

Salut Loost,
Ce n'est pas surement pas la meilleure solution car je ne suis pas un expert, je m'amuse juste à bidouiller des formules qui donnent le résultat que je cherche. Enfin jette déjà un oeil au fichier que j'ai mis dans mon message :)
La seule condition c'est que tout tes numéros se terminent tous par -xx.
Par exemple feuille1 A1 il y a " 000/215-01 " le -01 correspond bien à -xx donc ça va.
 

Pièces jointes

  • test1.xls
    33 KB · Affichages: 90
  • test1.xls
    33 KB · Affichages: 90
  • test1.xls
    33 KB · Affichages: 88

ant75

XLDnaute Junior
Re : Extraire données suivant conditions

J'ai ajouté une condition dans la formule pour t'éviter d'avoir des zéros dans la feuille 2.
 

Pièces jointes

  • test1.xls
    37.5 KB · Affichages: 100
  • test1.xls
    37.5 KB · Affichages: 105
  • test1.xls
    37.5 KB · Affichages: 100

Discussions similaires

Réponses
17
Affichages
312
Réponses
10
Affichages
407

Statistiques des forums

Discussions
312 001
Messages
2 084 473
Membres
102 581
dernier inscrit
Michou