Décaler plage de donnée en glissant

merguez59

XLDnaute Nouveau
Bonjour à tous en ces derniers moments de 2012!

j'ai 5 ville: paris, lille, toulouse, marseille et lyon
J'ai 4 produits: viande, poisson, fruit et légume

J'ai un tableau de synthèse qui va puiser les rangs de chacune de ces ville dans ces produits
Les rangs sont dans un onglet séparé, chaque "plage de donnée produit" est espacé de l'autre de 2 colonnes.

Je souhaite faire glisser ma recherchev de l'onglet synthese mais que la plage de donnée se décale de deux colonnes (les produits sont dans le même ordre).

voici en pièce jointe le fichier qui vous éclairera peut-être plus que mes mots!

Merci d'avance,

Bonne journée!
 

Pièces jointes

  • exemple decaler plage de donnée.xlsx
    9 KB · Affichages: 41

R@chid

XLDnaute Barbatruc
Re : Décaler plage de donnée en glissant

Bonjour,
en B2,
Code:
=RECHERCHEV($A2;DECALER(résultats!$A$1:$B$6;;EQUIV(B$1;résultats!$1:$1;0)-1);2;0)
@ tirer vers le bas et vers la droite
@ +

Edit : Salut Modeste :)
 
Dernière édition:

Modeste

XLDnaute Barbatruc
Re : Décaler plage de donnée en glissant

Bonjour merguez59,

Essaie
Code:
=RECHERCHEV($A2;DECALER(résultats!$A$1;;EQUIV(B$1;résultats!$A$1:$K$1;0)-1;6;2);2;FAUX)
en B2, à recopier en bas et à droite (pas besoin de valider en matricielle!?)

Edit: Bing! Désolé R@chid, pas rafraîchi! ... mais bonnes fêtes!