XL 2021 complétude de ligne

Rikko14

XLDnaute Nouveau
Bonjour,
de la même manière que la ligne 277, je souhaiterais savoir comment compléter les ligne 289 (somme de la colonne H en fonction du mois en colonne F) et 290 (somme colonne I en fonction de la colonne F).
Merci de votre aide.
 

Pièces jointes

  • VENTEStest.xlsx
    77.5 KB · Affichages: 4

Nairolf

XLDnaute Accro
Salut le forume, salut Rikko14,

Il te suffit juste d'adapter les plages à partir de la formule de la ligne 277.
Ce qui donne pour la ligne 289 :
Code:
=SOMMEPROD(($F$2:$F$263>0)*(MOIS($F$2:$F$263)=COLONNES($B:B));($H$2:$H$263))
A toi de jouer pour la ligne suivante.
 

Rikko14

XLDnaute Nouveau
@Nairolf

Heu désolé mais j'ai encore un souci, j'ai créé un onglet pour 2024 mais pour les formules il me compte déjà des frais de réparation et d'achat (ligne 109 et 111) sur le nouvel onglet, comment régler ce soucis ?

J'ai mis :

VB:
=SIERREUR(SOMME(FILTRE($H$2:$H$79;TEXTE($F$2:$F$79;"mmmm-aaaa")=N$92&"-"&TEXTE.APRES(CELLULE("nomfichier");"]");0));0)
en N109 que j'ai tiré jusqu'en Y109

et par extention :

Code:
=SIERREUR(SOMME(FILTRE($I$2:$I$79;TEXTE($F$2:$F$79;"mmmm-aaaa")=N$92&"-"&TEXTE.APRES(CELLULE("nomfichier");"]");0));0)
en N111 que j'ai tiré jusqu'en Y111

ensuite j'a fait un test en mettant ligne 63 pour janvier et 64 pour février mais j'ai rien en N109 et N111 et O109 et O111...


Merci de votre retour..

Cordialement.
 

Nairolf

XLDnaute Accro
Salut,
Tu as vu ton problème sur la non gestion de l'année et tu proposes les formules ci-dessus.
J'ai eu le même souci que toi à l'ouverture, mais en revalidant les formules, le calcul s'est bien fait.
C'est peut-être ta version d'Excel qui n'est pas compatible avec la fonction TEXTE.APRES(), utilise ceci à la place :
Code:
DROITE(CELLULE("nomfichier");4)
 

Rikko14

XLDnaute Nouveau
1703171009123.png
 

Statistiques des forums

Discussions
313 297
Messages
2 096 927
Membres
106 789
dernier inscrit
FrancoisVLD