Comparaisons tarifs

excfl

XLDnaute Barbatruc
Bonsoir le forum,

Recherche, pour chaque article, du fournisseur qui applique le tarif le moins élevé :
 

Pièces jointes

  • Tarifs fournisseurs --.xls
    22 KB · Affichages: 63

LAETI-TOINOU

XLDnaute Occasionnel
Bonsoir EXCELFi, bonsoir tout le monde,

Merci pour cette formule que je découvre.

A quoi sert le @ en début de formule ?

Merci de votre retour.

Bonne fin de journée.


Laëtitia
 

excfl

XLDnaute Barbatruc
Bonsoir LAETI-TOINOU,

Merci pour votre message.

=SI(SOMME(B2:F2)=0;"";INDIRECT(ADRESSE(1;EQUIV(MIN(B2:F2);B2:F2;0)+1)))

Je ne vois pas le @ dans la formule proposée.
 

LAETI-TOINOU

XLDnaute Occasionnel
Bonjour excfl, bonjour tout le monde,

Voici la formule de calcul qui apparait quand je sélectionne une cellule.
1644249735364.png



Laëtitia
 

Bernard_XLD

XLDnaute Barbatruc
Membre du Staff
Bonjour Excfl, laeti-toinou, le forum

Je ne vois pas le @ dans la formule proposée.
Voici la formule de calcul qui apparait quand je sélectionne une cellule.
Excfl n'est pas sous 365 mais toi oui, l'intersection implicite pour la compatibilité des formules des versions antérieures avec les matricielles dynamiques de 365 apparait sous 365 avec @ entre le = et la formule.
L'inverse est vrai aussi quand on lit un fichier créé sous 365 sur une version antérieure, on peut se retrouver avec des formules matricielles non nécessaires si on n'utilise pas le @ de l'intersection implicite.
https://www.excel-downloads.com/thr...-dynamiques-automatiques-dexcel-365.20057540/

Bien cordialement, @+
 

LAETI-TOINOU

XLDnaute Occasionnel
Bonjour excfl, bonjour tout le monde,

Grâce à toi je peux utiliser cette formule, et je t'en remercie.

Par contre, lorsque j'ai 2 résultats MIN identiques, EXCEL ne sait m'en faire ressortir qu'un seul, en l'occurence, le premier.

Comment faire pour qu'apparaissent les éventuels doublons ?

Merci beaucoup de ton retour.
J'espère qu'en posant cette question je reste bien dans ce fil de discussion.


Laëtitia
 

excfl

XLDnaute Barbatruc
Bonsoir Laëtitia,

"Par contre, lorsque j'ai 2 résultats MIN identiques, EXCEL ne sait m'en faire ressortir qu'un seul, en l'occurence, le premier"

Pour l'instant pas de réponse à ta question.
Seule contribution ce soir, une autre formule en H2 et à tirer vers le bas, qui confirme les résultats
de la colonne précédente :

=SIERREUR(INDEX(B$1:F$1;1;EQUIV(PETITE.VALEUR(B2:F2;1);B2:F2;0));"")
 

LAETI-TOINOU

XLDnaute Occasionnel
Bonjour Excfl, bonjour tout le monde,

Merci beaucoup pour ce complément.

Encore quelques mois sur le forum, et je vais devenir une vraie pro 😜.

Bonne journée.


Laëtitia
 

Statistiques des forums

Discussions
312 913
Messages
2 093 534
Membres
105 749
dernier inscrit
Mamadou221