XL 2013 Classement résultats différents produits

DaONE

XLDnaute Junior
Bonjour à tous 👍
J'ai un soucis avec un tableau. Alors j'ai un tableau de concours de pesée de fruits et légumes. Je n'arrive pas(onglet Feuil3), en fonction des produits sélectionnés(cellule C2), à avoir un classement des 8 plus gros produits( du plus lourd au moins lourd)
Je pensais que mes connaissances étaient largement suffisantes, que nenni.
Merci pour votre aide si précieuse 🙏
 

Pièces jointes

  • 2022 projet 00 RÉSULTATS lég fruits.xlsm
    138.1 KB · Affichages: 6

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonsoir DaOne,
Un essai en PJ avec :
VB:
Poids  : =SIERREUR(GRANDE.VALEUR(DECALER(agri;0;EQUIV($C$2;Tableau1[#En-têtes];0)-1);$B5);"")
Prénom : =SIERREUR(INDEX(agri;EQUIV($C5;DECALER(agri;0;EQUIV($C$2;Tableau1[#En-têtes];0)-1);0));"")
Le SIERREUR est utile car par ex Banane ne comporte que 6 pesées.
A noter un défaut de ces formules, n'accepte pas les ex aequo.
J'ai cependant mis une MFC de façon à voir les doublons. Quand un existe, il suffit de rajouter 0.1 gramme pour l'éliminer.
 

Pièces jointes

  • 2022 projet 00 RÉSULTATS lég fruits.xlsm
    138.7 KB · Affichages: 2
Dernière édition:

Statistiques des forums

Discussions
301 005
Messages
1 989 304
Membres
210 440
dernier inscrit
Jujess51