XL 2016 Chiffres dans une formule (phrase)

Collins

XLDnaute Occasionnel
Bonjours à tous,

Je reviens vous demander de l'aide.
Je bute pour insérer des valeurs (monétaires) dans une formule construite en phrase.
Tout est expliqué dans le fichier joint.

Ces valeurs se retrouvent en VRAI ou FAUX. Je ne sais comment les faire ressortir en nombre et de la je ne peux les incorporer dans la formule.
 

Pièces jointes

  • ESSAI.xlsx
    10.6 KB · Affichages: 4

piga25

XLDnaute Barbatruc
Bonjour,

Une solution à mettre en B7 :
VB:
=SI(F2>=0;"Somme demandée "&D2-F2&" € ("&D2&" € - "&F2&" €) arrondie à "&B4&" €.";"Somme demandée "&D2+F2&" € ("&D2&" € + "&F2&" €) arrondie à "&B4&" €.")

En B4 mettre pour faire directement l'arrondi :
Code:
=ARRONDI(SI(F2<0;D2-F2;D2-F2);1)
 

Collins

XLDnaute Occasionnel
Bonjour piga25

Merci pour ta réponse rapide mais il y a une erreur dans la phrase.
La somme dans la phrase reste à 19.45€ alors qu'il faut qu'elle se base sur la Cel B4 qui est à 32.45€ quand on a -6.50€ (<0)
et à 19.45€ quand on a 6.50€ (>=0)
 

piga25

XLDnaute Barbatruc
Re,
Oui en effet c'est l'erreur qui existait déjà en B4.
Donc pour remédier à cela, il faut mettre en dur la somme de 6,50€ dans une autre cellule (exemple en E2) ce qui donnera en B7
VB:
=SI(F2>=0;"Somme demandée "&D2-E2&" € ("&D2&" € - "&E2&" €) arrondie à "&B4&" €.";"Somme demandée "&D2+E2&" € ("&D2&" € + "&E2&" €) arrondie à "&B4&" €.")
puis corriger l'erreur en B4: D2 + E2; D2-E2
Code:
=ARRONDI(SI(F2<0;D2+E2;D2-E2);1)
 

Discussions similaires

Réponses
6
Affichages
294

Statistiques des forums

Discussions
313 287
Messages
2 096 831
Membres
106 758
dernier inscrit
JM9