XL 2013 Cellules "Vides" considérées non vides

glamlife

XLDnaute Nouveau
Bonjour à tous, (et bonne année ! ! )

Je travaille sur un fichier Excel 2013, et j'ai fait face à des problèmes assez originaux, et j'ai l'impression qu'ils viennent d’apparaître comme par magie (noire !) sur office 2013 ! !

Lorsque je fais une formule du genre :
=SI(CNUM(DROITE(B21;2))<=CNUM(DROITE($B$1;2));Nantes!V55;"")
Le plus important, c'est la fin de la cellule le "", qui m'affiche une cellule complètement vide.

Si je fais un graphique sur une cette plage de données, j'aimerai que ma courbe s'arrête quand les cellules sont vides.... et ma courbe passe à 0
J'ai vérifié les paramètres du graphique, et rien n'y fait, un copier coller valeur ne change rien et seul un "suppr" sur les cellules permet de faire afficher ma courbe comme je le veux (avec un "trou" dans la courbe".

J'ai déjà palier ce problème avec une boucle VB qui passait dans toutes mes cellule et qui supprimait le contenu des cellules vides (logique ;) )

Sub nettoyage1()

Dim celulle As Range

For Each celulle In Range("P2:BP538")
If celulle.Value = "" Then
celulle.Activate
celulle.Select
celulle.Clear
End If
Next
MsgBox "Fini"

End Sub


J'aimerai savoir si vous avez une solution, ou si cela a déjà été abordé dans le forum, si c'est le cas, je vais m'excuser et potasser ! !

Merci d'avance ! !

Glam
 

JHA

XLDnaute Barbatruc
Bonjour à tous,

Peut être modifier ta formule par:
Code:
=SI(CNUM(DROITE(B21;2))<=CNUM(DROITE($B$1;2));Nantes!V55;na())
Et ton graphique devrait se faire correctement.

Pour ne pas voir #n/a dans ta cellule, mettre une MFC si erreur police blanche.

JHA
 

Discussions similaires

Statistiques des forums

Discussions
312 929
Messages
2 093 702
Membres
105 791
dernier inscrit
Restosducoeur