XL 2016 Calcul cellules vides sous conditions multiples

egt

XLDnaute Nouveau
Bonjour à tous,

Le contexte :

  • je dois m'appuyer sur un fichier planning de collaborateurs dans lequel seuls leurs jours d'absence sont identifiés. Une cellule vide signifie que le collaborateur est présent.
  • En ordonnée, ce tableau possede à gauche en colonne le nom des collaborateurs avec en colonne adjacente leur appartenance à une équipe technique
  • En abscisse, la date pour chaque jour de l'année
  • et dans la matrice, leur absence identifiée par "RTT", "CP"...
Mon obectif : Déterminer par équipe, le nbre de jour de présence total par semaine (cumul des collab par équique par semaine)

J'ai bien tenté les sommeprod, somme.si.ens et autres nb.vide mais sans succès.

Merci pour vos idées
 

egt

XLDnaute Nouveau
Bjr,
la formule ne me renvoie aucune donnée :(
On m'a proposé egalement cette formule qui fonctionne parfaitement
=SOMMEPROD(($C$3:$N$12="")*($B$3:$B$12=$B16)*($C$1:$N$1=CNUM(DROITE(C$15;NBCAR(C$15)-1))*(JOURSEM($C$2:$N$2;2)<6)))
Mais maintenant je cherche à me passer de la ligne "Semaine" (ligne1) et déduire la semaine directement à partir de la date
Merci
 

Statistiques des forums

Discussions
313 197
Messages
2 096 121
Membres
106 502
dernier inscrit
Jc_dan