astuce #DIV/0!

P

philoux

Guest
pour eviter #DIV/0!
ma formule:dans cellule B11
=(((8,03*(B9*24)/B10)*(1,6))-(1))*(0,433)*B10

si je ne rempli pas B9 et B10 la (celluleB11)ou ma formule ce trouve me bloque pour faire des sommes dans une autre cellule B47 avec cette formule
=SOMME(B11;B15;B19;B23;B27;B31;B35;B39;B43)
merci pour votre aide
 
G

GIBI

Guest
Bonjour,



Il faut réflchir et tu as la réponse.

Si tu ne veux pas divisé par zero, tu le dis à excel :

=si (B10<>0;=(((8,03*(B9*24)/B10)*(1,6))-(1))*(0,433)*B10

;0)

CaD si (B10<>0; je calcule ; je met zero)



Trop bête non!
 

anuky

XLDnaute Occasionnel
Bonjour,

il faut rajouter SI(ESTERREUR ta_formule; '';ta_formule) comme suit :

SI(ESTERREUR(((8,03*(B9*24)/B10)*(1,6))-(1))*(0,433)*B10;'';=(((8,03*(B9*24)/B10)*(1,6))-(1))*(0,433)*B10)

je ne suis pas certain pour le nombre de paranthèses pour plus d'info va voir l'aide sur la formule ESTERREUR.

ce qui permet de ne rien afficher dans ta case si le resultat de ton calcul renvoi une erreur.

Bon courrage.
 

Statistiques des forums

Discussions
312 924
Messages
2 093 669
Membres
105 781
dernier inscrit
Dominique G.