arrondi...

Y

Yannick

Guest
Bonjour
Lorsque l'on utilise la fonction ARRONDI, Excel incrémente automatiquement à partir du chiffre 5 inclu.
Je souhaiterai incrémenter à partir du chiffre 5 exclu.

Ex: 12.345 donne 12.35 lorsque l'on arrondit à 2 chiffres après la virgule.
Je souhaiterai, uniquement dans ce cas (c'est à dir que le 3ème chiffre après la virgule est un 5 et qu'il n'y a rien après celui-ci) arrondir à 12.34

Merci
 
G

GIBI

Guest
bonjour,


Si il s'agit d'arrondir à la valeur inférieur si la troisième décimale est <=5

il faut ajouter 0,004 au chiffre puis ne garder que 2 décimales soit en excel TRONQUE(1,345+,004;2) ===> 1,34

TRONQUE(1,346+,004;2) ===> 1,35
 

andré

XLDnaute Barbatruc
Salut Yannick et Pascal76, + GIBI que je viens de voir !

Pascal, je ne comprends pas ta formule.
Pour moi : =ARRONDI(A1-0.001;2) suffit amplement

La solution de GIBI est la même, mais prise à l'envers.
Comme je n'y avais encore jamais songé, je la classe dans un petit coin de ma tête (mon dieu, je viens d'aller voir, ce qu'il y a encore comme place, mais il faudra d'abord enlever les poussières - lol).

Â+
 

Discussions similaires

Statistiques des forums

Discussions
300 718
Messages
1 986 643
Membres
209 555
dernier inscrit
Cookone