allegement calcul

zumye

XLDnaute Occasionnel
bonjour le forum
je cherche à allerger ma feuille originale qui contient une multitude de formule. le fichier devient lourd quand celle ci est copiée plus d'une vaingtaine de fois.

1-existe t il une formule qui peut me compter directement le nombre de "P" que j'ai dans une colonne? sans mettre des conditions a chaque ligne comme j'ai actuellement.

2-j'ai cette formule : =SI(OU(I22<>"";J22<>"");((NBVAL(I22:O22))*($G22+AG22+0,3));0)+SI(AD23="";0;(NBVAL(AA23:AF23)*(AG23-AG22)))
copiée de nombreuse fois dans une colonne.(AQ22:AQ114)

ex:
=SI(OU(I22<>"";J22<>"");((NBVAL(I22:O22))*($G22+AG22+0,3));0)+SI(AD23="";0;(NBVAL(AA23:AF23)*(AG23-AG22)))
ensuite
=SI(OU(I25<>"";J25<>"");((NBVAL(I25:O25))*($G25+AG25+0,3));0)+SI(AD26="";0;(NBVAL(AA26:AF26)*(AG26-AG25)))
etc
existe -il un moyen d'ecrire une macro qui pourrait remplacer ces longues formules?

3-et une question qui n'a rien a voir:
je protege ma page original au démarrage par

Private Sub Workbook_Open()
Sheets("Original").Protect userinterfaceonly:=True
End Sub

par defaut il autorise juste l'utilisateur à selectionner les cellulles verrouilléé et dévérouillée , comment par défaut je pôurrai lui rajouter d'autre option comme "autoriser le masquage" ou autres?

merci
 

Discussions similaires

Statistiques des forums

Discussions
312 149
Messages
2 085 772
Membres
102 970
dernier inscrit
JMaurice