aide sur une formule

seigneurchris

XLDnaute Nouveau
bonjour voici ma formule en F24

= si( E24=0;"0";si(E24<=1;(G23+C24)*E24)) ça c'est ok...

mais de la dans la cellule E24 il me met "FAUX"...

cellule G23 est un total
cellule C24 est un montant fixe
cellule E24 est le pourcentage (qui se trouve en cellule R36 mais le pourcentage de R36 ne se sera qu'en fin de mois (juillet)...
En R36 la valeur est de -100% puisque le mois n'a pas commencé.
Et chaque jours que le montant sera mit le -100% diminuera.

d'ou le "FAUX" que j'aimerai bien faire disparaitre en cellule E24
c'est pour ça que j'avais utilisé le SI & OU mais de la j'avais #VALEUR!
Et de la j'aimerai que la cellule soit ou vide ou 0 ..

je sais pas si c'est clair pour vous comme j'ai expliquer...



d'avance merci pour votre aide

ps: ATTENTION je travail sous mac office 2008...
 

Pièces jointes

  • Calcul carm.xls.zip
    24.7 KB · Affichages: 41
Dernière édition:

jeanpierre

Nous a quitté
Repose en paix
Re : aide sur une formule

Bonjour seigneurchris, et Bienvenue sur le forum,

Déjà, pourquoi =si(e24=0;"0" .... =si(e24=0;0; ... serait mieux...

Ensuite, pourquoi déposer ton fichier sur un autre site (inaccessible d'ailleurs puisque l'on tombe sur la page d'accueil)

Ou tu poses ta question ici avec ton fichier ici ou tu le fais ailleurs.

En attente donc..

Jean-Pierre
 
Dernière édition:

seigneurchris

XLDnaute Nouveau
Re : aide sur une formule

j'ai rectifier pour le fichier Jean Pierre ;-) tu as du arriver au moment ou je changeais..

le temps de trouver comment envoyer le fichier...

aaah ok je pensais que je devais mettre E24 pour la cellule...
 
Dernière édition:

Tibo

XLDnaute Barbatruc
Re : aide sur une formule

Bonjour,

Un test SI demande deux réponses :

- une si VRAI
- une si FAUX

il te manquait pour le 2ème test la réponse si FAUX

Je te propose cette petite correction en H22 :

Code:
=SI(G9<G22;CAR(147);SI(G9>G22;CAR(148);""))

@+
 

seigneurchris

XLDnaute Nouveau
Re : aide sur une formule

=SI(G9<G22;CAR(147);SI(G9>G22;CAR(148);""))

a se moment la j'ai #valeur! sur le reste des cellules F ainsi que les cellules G... c'est donc pas bon lool

de plus tu ne reprends pas le restant de ma formule...(G23+C24)*E24)

c'est d'ailleurs la base de ma formule..
 
Dernière édition:

Tibo

XLDnaute Barbatruc
Re : aide sur une formule

re,

...voici ma formule en F24

= si( E24=0;"0";si(E24<=1;(G23+C24)*E24)) ça c'est ok...

mais de la dans la cellule E24 il me met "FAUX"...

le souci, c'est qu'en F24, la formule sur le fichier joint ne ressemble pas vraiment à ça ...

A te (re)lire avec plus de détails

@+

Edit :

Teste cette formule en F24 :

Code:
=SI(E24=0;0;SI(E24<=1;(G23+C24)*E24;0))

Sans trop de conviction, car pas vraiment compris ce qu'il fallait obtenir

@+
 
Dernière édition:

seigneurchris

XLDnaute Nouveau
Re : aide sur une formule

en fait non il y a juste la fin de la formule (G23+C24)*E24)

et j'aurais voulu que si F24 = 0 mettre 0
ou si F24 sup à 1 alors faire la formule (G23+C24)*E24)

mais a se moment la ça met "FAUX" de la j'ai essayer avec SI et OU mais ça n'a pas été très concluent ...

de plus avec SI et OU j'avais #VALEUR! ..


donc je suis rester sur la formule toute simple (G23+C24)*E24)
 

jeanpierre

Nous a quitté
Repose en paix
Re : aide sur une formule

Re, Bonsoir Tibo,

De ton texte on peut tirer :

Si F24=0 alors 0 sinon si F24>1 alors ta formule, sinon et entre 0 et 1 on ne fait rien ce qui donne :

=SI(F24=0;0;SI(F24>1;(G23+C24)*E24);"")


Bonne soirée.

Jean-Pierre
 

seigneurchris

XLDnaute Nouveau
Re : aide sur une formule

Salut
me revoilà après plusieurs essais j'ai trouver une solution assez simple...

au lieu de vouloir absolument modifié ma formule en F24
j'ai modifié ma formule E24 en =SI(R36<>-100%;R36;"0")
de la F24 se retrouve =(G23+C24)*E24

et tout le monde sais que 100*0=0...

Merci pour votre aide

problème résolu :D
 

Statistiques des forums

Discussions
312 812
Messages
2 092 309
Membres
105 354
dernier inscrit
Green2