XL 2019 vba - chercher numéros manquants - ressortir les doublons

douguy

XLDnaute Junior
Bonjour le forum.

Nouvel appel à l'aide pour un exercice logique où je ne sais pas comment procéder.
J'ai une liste d'adresse IP

1 - En fonction d'un préfixe je veux ressortir la liste des suffixes utilisés avec ce préfixe.
2 - Ensuite je dois définir quels suffixes ne sont pas utilisés (de 1 à 253)
3 - il y a des doublons dans la liste que je veux faire ressortir

j'ai réussi le point 1 avec une formule que j'étend sur la plage
=+SI(GAUCHE(B$1;9)=GAUCHE(A71;9);CNUM(DROITE(A71;NBCAR(A71)-10));"")
je supprime ensuite les cellules vides par macro
j'ai utilisé l'enregistreur

Sub Macro9()
Range("B3").Select
Range(Selection, Selection.End(xlDown)).Select
Selection.SpecialCells(xlCellTypeFormulas, 22).Select
Selection.Delete Shift:=xlUp
End Sub

je ne sais pas comment procéder pour le point 2
pour le point 3 : je pensais utiliser la MEC doublon puis le fitre spécial pour ressortir les doublons puis copier coller dans la plage qui va bien

Merci beaucoup pour vos contributions.
 

Statistiques des forums

Discussions
299 847
Messages
1 979 562
Membres
206 773
dernier inscrit
becaye80