Valeur dans cellelule B1 suivant val cell A1

lmylvc

XLDnaute Occasionnel
Hello

Je cherche une formule qui permet de mettre un prix dans la colonne B36 si la donnée saisie dans la colonne A36= exemple "Porte" et un autre prix si la valeur saisie egale "aile"

A titre d'exemple j'ai essayé cette formule mais ça ne marche pas

'=SI(ou(N36="Porte G";9.35;SI(N36="Porte D";9.1;SI(N36="Panneau arr";7.5;SI(N36="Capot";8.8;SI(N36="Calandre";4.8;SI(N36="Bouclier";5.4;SI(N36="Aile av G";6.1;SI(N36="Aile av D";6.0;SI(N36="Aile arr D";5.3;SI(N36="Aile arr G";5.3;"???")))))

Please Help My

Vincent:)
 

mth

XLDnaute Barbatruc
Re : Valeur dans cellelule B1 suivant val cell A1

Bonjour,

"En l'état", ça doit venir du OU(), à retirer sui j'ai bien compris:

Code:
=SI(N36="Porte G";9.35;SI(N36="Porte D";9.1;SI(N36="Panneau arr";7.5;SI(N36="Capot";8.8;SI(N36="Calandre";4.8;SI(N36="Bouclier";5.4;SI(N36="Aile av G";6.1;SI(N36="Aile av D";6;SI(N36="Aile arr D";5.3;SI(N36="Aile arr G";5.3;"???"))))))))))

(ça serait sans doute plus simple de faire une liste, et d'aller rechercher les prix avec un RECHERCHEV() )

@ +

mth
 

lmylvc

XLDnaute Occasionnel
Re : Valeur dans cellelule B1 suivant val cell A1

<<<<<<Hello mth

Merci pour ta réponse

Tu as raison,cette solution fonctionne, toutefois, à la 8eme condition il m'indique un pb.
Suis-je limité en nbre de conditions avec cette formule ??

Vincent
 

mth

XLDnaute Barbatruc
Re : Valeur dans cellelule B1 suivant val cell A1

re ... :)

Pour jouer, un exemple avec RECHERCHEV() en PJ, ça simplifie pas mal ....

Très bonne journée à toi,

mth
 

Pièces jointes

  • lmy.xls
    34.5 KB · Affichages: 43
Dernière édition:

mth

XLDnaute Barbatruc
Re : Valeur dans cellelule B1 suivant val cell A1

re :)

nos messages se sont croisés ..;
Oui effectivement je n'avais pas noté, tu es limité en nombre de conditions sur Excel 2003 (7 conditions).

... Vois si la formule ci-dessus avec RECHERCHEV() te convient ...

@ +

mth
 

alexane

XLDnaute Occasionnel
Re : Valeur dans cellelule B1 suivant val cell A1

Bonjour
Si je ne me trompe pas, excel n'accepte pas plus de 7 si imbriqués les uns dans les autres; il faut que tu utilises une recherchev
Je vous joins un fichier d'exemple
 

Pièces jointes

  • si imbriqué.xls
    18.5 KB · Affichages: 36

Discussions similaires

Statistiques des forums

Discussions
299 878
Messages
1 979 749
Membres
206 856
dernier inscrit
Proux