XL 2010 Utiliser la fonction si dans un tableau

bobafric

XLDnaute Occasionnel
Dans une cellule on peut taper des chiffres de 1 à 10 mais si ces chiffres de 1 à 10 existent dans la colonne et la ligne ne pas inscrire la valeur correspondante.
C'est à dire si on veut inscrire 1 3 5 dans une cellule A5 et que 5 existe dans la col A ou la ligne 5 le résultat sera 1 3
J'espère être assez clair et merci d'avance.
 

bobafric

XLDnaute Occasionnel
Excusez moi j'avais oublier de vous saluer
Dans une cellule on peut taper des chiffres de 1 à 10 mais si ces chiffres de 1 à 10 existent dans la colonne et la ligne ne pas inscrire la valeur correspondante.
C'est à dire si on veut inscrire 1 3 5 dans une cellule A5 et que 5 existe dans la col A ou la ligne 5 le résultat sera 1 3
J'espère être assez clair et merci d'avance.
 

Staple1600

XLDnaute Barbatruc
Bonjour

Tu peux utiliser donnés/validation pour empêcher la saisie de doublon
Tu sélectionnes ta colonne (ici pour l'exemple la colonne)
Puis tu fais Données/Validation ->Personnalisée
et tu saisis cette formule
=NB.SI(A:A;A1)=1

Si difficultés, regarde sur le net, il y a de nombreux tutos.
 

bobafric

XLDnaute Occasionnel
Bonjour

Tu peux utiliser donnés/validation pour empêcher la saisie de doublon
Tu sélectionnes ta colonne (ici pour l'exemple la colonne)
Puis tu fais Données/Validation ->Personnalisée
et tu saisis cette formule
=NB.SI(A:A;A1)=1

Si difficultés, regarde sur le net, il y a de nombreux tutos.
Salut Staple
Je pense m'être trompé et qu'il faut une macro pour résoudre le problème.
Je joins un fichier pour exemple
Cordialement
 

Pièces jointes

  • Fonction SI.xlsm
    9.2 KB · Affichages: 3

Discussions similaires

Réponses
1
Affichages
517

Statistiques des forums

Discussions
299 952
Messages
1 980 339
Membres
207 061
dernier inscrit
nadirasalifou