une cellule egale un nombre

S

sir

Guest
bonjour,
voila j'ai besoin d'attribuer un nombre en fonction de la cellule cochée'x'

exemple

j'ai b2,c2,d2si je mets une croix dans l'une de ces cellules alors j'aimerais qu'en a2 si b2 est coché voir le nombre 1, si c'est c2 j'aimerais qu'en a2 voir le nombre 2 etc

merci pour votre aide
 

Gael

XLDnaute Barbatruc
Bonjour Sir, Christophe, Jocelyn,

Avec une recherche:

=SI(ESTNA(EQUIV('X';$B$2:$I$2;0));0;EQUIV('X';$B$2:$I$2;0))

Si aucune croix n'est saisie, A2 sera égal à 0, sinon il affichera l'adresse de la croix de 1 à n.

Si plusieurs croix sont saisies, seule la première est prise en compte.

Pour éviter la saisie de plusieurs croix, tu peux mettre une formule de validation sur l'ensemble de la plage avec données validation.

@+

Gael
 

Gael

XLDnaute Barbatruc
Rebonjour,

Pour la validation, tu sélectionnes la plage de cellules concernées par exemple B2:I2 puis tu fais données validation personnalisée et tu mets la formule suivante:

=NB.SI($B$2:$I$2;'X')<=1

Un message d'erreur apparaît (que tu peux personnaliser) si 2 croix sont saisies dans la plage.

@+

Gael
 
J

JJ59

Guest
Bonjour Sir, Jocelyn, Creepy; Gael, le Forum


Voici une autre approche


Bon aprés-midi à tous

JJ59 [file name=CelluleNbre.zip size=1816]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/CelluleNbre.zip[/file]
 

Pièces jointes

  • CelluleNbre.zip
    1.8 KB · Affichages: 85

excalibur

XLDnaute Impliqué
Bonjour Sir, Christophe, Jocelyn,gael par vba au niveau de l evenement Option Explicit
Private Sub Worksheet_SelectionChange(ByVal Target As Range)
If Target.Address = '$B$2' And [b2] = 'x' Then [a2] = 1: [c2] = '': [d2] = ''
If Target.Address = '$C$2' And [c2] = 'x' Then [a2] = 2: [b2] = '': [d2] = ''
If Target.Address = '$D$2' And [d2] = 'x' Then [a2] = 3: [c2] = '': [b2] = ''
End Sub' salutations
 

Discussions similaires

Réponses
1
Affichages
331