Somme si

steph71

XLDnaute Occasionnel
Bonjour à tous


j'ai de nouveau un pb sur mon appli pour sommer en fonction de critères.

Soient les données suivantes :

Dossier TYPE AG
1 A
2 A
3 C
4 D
5 E
1 A
1 A
4 D

j'aimerais un total dans une cellule par TYPE AG
Ainsi TYPE AG A = 2 (dossiers 1 et 2)

Comment faire pourqu'il ne me compte pas le dossier 1 comme 3 type AG A différents

Merci d'avance et bonne journée
 

Jocelyn

XLDnaute Barbatruc
Bonjour le Forum,
Bonjour steph71, Celeda,

bon alors un petit essai mais en priant pour que monique passe par la.


Jocelyn [file name=steph71.zip size=1799]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/steph71.zip[/file]
 

Pièces jointes

  • steph71.zip
    1.8 KB · Affichages: 12
  • steph71.zip
    1.8 KB · Affichages: 12
  • steph71.zip
    1.8 KB · Affichages: 12
J

JJ59

Guest
Bonjour steph71, Celeda, Jocelyn

Une petite tentative de réponse.
2 colonnes ajoutées qui peuvent être masauées.

Bon aprés-midi

JJ59 [file name=Steph71_20051021154055.zip size=2446]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/Steph71_20051021154055.zip[/file]
 

Pièces jointes

  • Steph71_20051021154055.zip
    2.4 KB · Affichages: 10

Gael

XLDnaute Barbatruc
Rebonsoir à tous,

Désolé jocelyn, je n'avais pas encore regardé ta solution. je ne comprends pas bien pourquoi, mais dans ma formule, je n'ai pas besoin de faire '-1'.

Par contre je n'avais pas vu le coup du n° de dossier qui effectivement pose un problème.

Mais comme tu l'as annoncé, monique va surement venir à la rescousse.

@+

Gael
 

Gael

XLDnaute Barbatruc
re rebonsoir à tous,

Après quelques tests, il reste un cas qui est mal géré par cette dernière formule: lorsque toute la table 'type AG' contient la même lettre, dans ce cas il na faut pas faire '-1'.

Si ce cas peut se prosuire, la formule est à compléter ainsi:

=SOMMEPROD((N(FREQUENCE(Dos*(Typ=$A$1);Dos*(Typ=$A$1))>0)))-SI(NB.SI(Typ;$A$1)<NBVAL(Typ);1;0)

@+

Gael
 

Discussions similaires

Statistiques des forums

Discussions
300 890
Messages
1 988 170
Membres
210 095
dernier inscrit
Ratahiry