Somme multicritères 2

os_rouen

XLDnaute Junior
Re-Bonjour,

La fonction fournie fonctionne parfaitement mais comment traiter le cas où un, deux ou les trois critères sont vides et lui faire caculer la somme sur toute la liste?

D'avance merci
[file name=SommeprodTroisCriteres_20051020132835.zip size=1944]http://www.excel-downloads.com/components/com_simpleboard/uploaded/files/SommeprodTroisCriteres_20051020132835.zip[/file]
 

Pièces jointes

  • SommeprodTroisCriteres_20051020132835.zip
    1.9 KB · Affichages: 21
G

GIBI

Guest
bonjour,

pour tenir compte du critère vide ('') il faut faire une condition de type 'OU' ce qui correspond a une addition


=SOMMEPROD((($A$2:$A$19=$C$2)+($C$2=''))*((($B$2:$B$19>$D$2)*($B$2:$B$19<$E$2))+($E$2=''))*$B$2:$B$19)


il suffit de demander
 

Dan

XLDnaute Barbatruc
Bonjour,

Tu peux introduire une condition SI dans ta formule SOMMEPROD. Par exemple dans ton fichier :

=SI(OU(C2=0;D2=0;E2=0);SOMME(B2:B20);FAUX)

Condition Vrai : SOMME(B2:B20)
Condition FAUX : mets la formule SOMMEPROD à la place de 'FAUX'

Tout cela à placer en F2.

:)

Edition : ce que je t'ai proposé n'est pas correct. En effet, la fonction calcul toujours le max dès qu'il y a une veleur 0 dans une des trois cellules.
Prends donc la proposition de GIGI qui fait fait la somme par critère encodé.
La condition OU dans une formule SOMMEPROD est représentée par un + tandis que la fonction ET par un *.

:)

Message édité par: Dan, à: 20/10/2005 13:53
 
G

GIBI

Guest
bonjour,

pour tenir compte du critère vide ('') il faut faire une condition de type 'OU' ce qui correspond a une addition


=SOMMEPROD((($A$2:$A$19=$C$2)+($C$2=''))*((($B$2:$B$19>$D$2)*($B$2:$B$19<$E$2))+($E$2=''))*$B$2:$B$19)


il suffit de demander
 

Statistiques des forums

Discussions
300 890
Messages
1 988 179
Membres
210 097
dernier inscrit
Leboucanier