Somme heures

Jean-luc1311

XLDnaute Occasionnel
Bonjour,

Je souhaite faire la somme des heures au format hh:mm dema base de données.
J'utilise la formule suivante:

=SOMMEPROD(((MOIS(Date)=MOIS($B59))*(Heures_AM=C$58)))
En retour j'obtiens "N/A"

Cette formule fonctionne bien avec des entiers mais pas avec des heures.
Un petit conseil serait le bienvenu.

Merci
 

Tibo

XLDnaute Barbatruc
Re : Somme heures

Bonjour,

Sans voir le fichier qui va avec, pas facile de t'aider.

Je serais tenté de te dire qu'il y a peut-être des données non numériques dans tes différentes plages (comme de chaînes vides par exemple).

Vérifier également que tes plages soient de la même dimension (même nombre de cellules).

A te (re)lire avec un extrait de ton fichier

@+
 

Tibo

XLDnaute Barbatruc
Re : Somme heures

re,

Dans ta formule en C3, il faut supprimer le *24

Tu as des données au format Heure en colonne E de l'onglet Heures et tu as également des données au format Heure en colonne C de l'onglet Récap. Il n'est donc pas besoin de convertir.

Par contre, dans l'exemple joint, il n'y a pas de #N/A

Donc difficile de t'aider sur ce souci sur la base du fichier joint.

@+
 

Jean-luc1311

XLDnaute Occasionnel
Re : Somme heures

Bonsoir à tous.

J'ai résolu mon problème.
Après modification de ma formule et du format de la cellule, je retrouve bien mes valeurs.
Pour ceux que cela intéresse, je joins mon fichier et reste ouvert à tous commentaires.
Bonne soirée.
 

Pièces jointes

  • Heures.xls
    25 KB · Affichages: 78
  • Heures.xls
    25 KB · Affichages: 80
  • Heures.xls
    25 KB · Affichages: 74

Discussions similaires

Membres actuellement en ligne

Aucun membre en ligne actuellement.

Statistiques des forums

Discussions
299 930
Messages
1 980 158
Membres
207 009
dernier inscrit
Cartereau