Somme avec condition

Azerty13

XLDnaute Junior
Bonjour à tous je reviens à vous une nouvelle fois...

J'ai mis un exemple simplifié de ce que je souhaite faire en pièce jointe. Vous verrez que je m'en sors avec le sommeprod, ce n'est pas un problème.:)

J'ai 4 critères de sommes. On peut sans problème les agréger avec un sommeprod. Sauf que je souhaiterais mettre en place une formule, qui, lorsqu'un ou plusieurs critères n'est pas renseigné fasse en sorte de recalculer selon les critères restants...

exemple:
Activité et entité sont renseignées.
Division uniquement est renseignée.
Entité et Client sont renseignées...

ETC

Merci d'avance pour votre aide qui me sera plus que précieuse :eek:
 

Pièces jointes

  • exceldown.xls
    14 KB · Affichages: 59
  • exceldown.xls
    14 KB · Affichages: 64
  • exceldown.xls
    14 KB · Affichages: 63

ROGER2327

XLDnaute Barbatruc
Re : Somme avec condition

Bonjour Azerty13
Essayez ceci :
Code:
[COLOR="DarkSlateGray"][B]=SOMMEPROD((((Division=I11)+(""=I11))>0)*(((activité=J11)+(""=J11))>0)*(((entité=K11)+(""=K11))>0)*(((client=L11)+(""=L11))>0)*ventes)[/B][/COLOR]
ROGER2327
#4218


Lundi 23 Absolu 138 (Sainte Varia-Miriam, amphibie, SQ)
9 Vendémiaire An CCXIX
2010-W39-4T16:07:05Z
 

job75

XLDnaute Barbatruc
Re : Somme avec condition

Bonjour Azerty13,

Entrer en B14 la formule matricielle :

Code:
=SOMME(SI(A14<>"";mois=A14;1)*SI(I$11<>"";Division=I$11;1)*SI(J$11<>"";activité=J$11;1)*SI(K$11<>"";entité=K$11;1)*SI(L$11<>"";client=L$11;1)*ventes)

A valider par Ctrl+Maj+Entrée.

Fichier joint.

Edit : il y a du monde, salut Roger, tototiti :):)

A+
 

Pièces jointes

  • exceldown(1).xls
    14.5 KB · Affichages: 45

ROGER2327

XLDnaute Barbatruc
Re : Somme avec condition

Re...
(...)
C'est surtout que je n'y suis pas arrivé avec SOMMEPROD :D

Puis l'idée m'est venue..
Il ne faut pas le dire !

"Puisque ces événements nous dépassent, feignons d'en être les organisateurs" disait Cocteau...​
ROGER2327
#4221


Lundi 23 Absolu 138 (Sainte Varia-Miriam, amphibie, SQ)
9 Vendémiaire An CCXIX
2010-W39-4T16:39:30Z
 

Azerty13

XLDnaute Junior
Re : Somme avec condition

Merci à tous, merci pour l'ensemble de vos réponses !!! C'est vraiment génial ! Par contre avec le BDSOMME comment prendre en compte mes mois qui sont en cellule a14 et a15 ?

Merci beaucoup pour votre aide, vous êtes des chefs !:)
 

ROGER2327

XLDnaute Barbatruc
Re : Somme avec condition

Bonjour Azerty13
Puis je t'envoyer mon fichier par message privé ?
Non. Ma position est que ce forum est un forum d'entraide sur lequel tous les intervenants peuvent bénéficier du savoir de tous les intervenants. Mais vous pouvez exposer votre problème et déposer un classeur avec quelques situations concrètes sur le forum. Si je suis capable de trouver une solution, je le ferai. Si j'en suis incapable, un (une) autre saura le faire...​
Cordialement,

ROGER2327
#4226


Mardi 24 Absolu 138 (Saints Rakirs et Rastrons, porte-côtelettes, SQ)
10 Vendémiaire An CCXIX
2010-W39-5T10:12:10Z
 

job75

XLDnaute Barbatruc
Re : Somme avec condition

Bonjour le fil :)

Pour tenir compte des cellules A14 A15... on peut compléter la formule de Roger.

Entrer en B14 :

Code:
=SOMMEPROD(SIGNE(((mois=A14)+(""=A14))*((Division=I$11)+(""=I$11))*((activité=J$11)+(""=J$11))*((entité=K$11)+(""=K$11))*((client=L$11)+(""=L$11)))*ventes)

A+
 

Pièces jointes

  • exceldown(2).xls
    14.5 KB · Affichages: 43

Statistiques des forums

Discussions
299 728
Messages
1 978 789
Membres
206 395
dernier inscrit
Bilina