XL 2019 Saisie automatique par formule RechercheV

Optimal

XLDnaute Junior
Bonjour.

Me voici à nouveau confronté à un problème que je n'arrive pas à résoudre.

J'ai dans une feuille "Saisie" un tableau nommé "TblSaisie" qui est alimenté manuellement ( je ferai certainement un formulaire de saisie par la suite ) avec des valeurs qui peuvent avoir plusieurs occurrences de même nom.

Exemple :

Acheter Louer en A3
Iliad en A4
Acheter Louer en A5
Onxeo en A6
Iliad en A7
Europlasma en A8
Acheter Louer en A9

J'ai une seconde feuille "Acheter Louer"avec un tableau destiné à être verrouillé totalement.

J'ai besoin de récupérer les valeurs en colonne C D et E de la feuille " Saisie "( il y'en aura d'autres par la suite )

En C6 :
J'utilise la formule RECHERCHEV qui prend en cellule B4 la valeur à rechercher dans ma feuille "Saisie" comme ceci
=RECHERCHEV($B$4;Tbl_Saisie;3;FAUX)

Pour la 1ère occurrence pas de souci ça fonctionne tout le temps.
Mais comment faire pour que en C7 je récupère la deuxième occurrence et en C8 la 3ème occurrence etc...

Fichier en exemple de ce que je cherche à faire avec le tableau en cours et le tableau attendu

Merci d'avance
 

Pièces jointes

  • Exemple Optimal _ Saisie auto.xlsx
    17.4 KB · Affichages: 7

Optimal

XLDnaute Junior
@JHA

Bonsoir

Merci pour le début de piste.
Je n'ai pas encore regardé mais en attendant j'ai trouvé une solution qui vaut ce qu'elle vaut

Dans ma feuille de saisie je met une colonne qui sera masquée par la suite.
Dedans je saisi la formule suivante : =[@Titre]&[@[N° Index]]
Ce qui me donne le Nom que je recherche + le Numéro d'index.

Ensuite dans ma feuille de travail je met la formule suivante :
=RECHERCHEV(B4&B7;Saisie!F3:G9;2;FAUX) et la ça fonctionne.

Me reste a trouver comment attribuer dans ma feuille de saisie le numéro d'index suivant en fonction de l’occurrence.

Je regarde maintenant votre solution
 

Discussions similaires