XL 2013 Retirer des chiffre dans une colonne

Kayser

XLDnaute Junior
Bonjour

comment retirer des chiffres dans une colonne
Exemple:
dans la colonne A je souhaite que tous les 2 "coté gauche" soient retirés et celle de B "coté gauche 014"
Ya t'il une manip pour réaliser cette fonction?

Merci d'avance
 

Pièces jointes

  • excelforum.xls
    232.5 KB · Affichages: 12

jui42

XLDnaute Junior
Bonjour, dans l'onglet "Donnée" utilisez l'outil convertir, puis choisissez "Largeur fixe".
Vous pourrez placez un "delimiteur" au niveau du 2. Cependant je pense que cela supprimera également les 0 , je cherche une solution VBA et je reviens vers vous si cela ne vous convient pas.
Cdt,
 

soan

XLDnaute Barbatruc
Inactif
Bonsoir Kayser, jui42,

sur "Feuil1" :

tes 2 colonnes A et B sont inchangées.

1) fais Ctrl e ➯ en colonne A, ça a bien enlevé tous les "2"
du début de tes données, sans rien modifier d'autre.​

remarque : ça n'a pas changé la valeur qui était en A276 :
c'est toujours "807489" ; ça ne commençait pas par "2".

2) fais Ctrl f ➯ en colonne B, ça a bien enlevé tous les "014"
du début de tes données, sans rien modifier d'autre.​

remarque : la plage B349:B363 était vide avant exécution
de la 2ème macro ; c'est resté pareil.

si besoin, tu peux demander une adaptation.
à te lire pour avoir ton avis. ;)



code VBA (25 lignes) :

VB:
Option Explicit

Private Sub Job(d$, c As Byte)
  Dim n&: n = Cells(Rows.Count, c).End(3).Row
  If n = 1 And IsEmpty(Cells(1, c)) Then Exit Sub
  Dim s$, k As Byte, i&
  k = Len(d): Application.ScreenUpdating = 0
  For i = 1 To n
    With Cells(i, c)
      s = .Text
      If Left$(s, k) = d Then
        .Value = Right$(s, Len(s) - k)
      End If
    End With
  Next i
End Sub

Sub SetColA()
  If ActiveSheet.Name = "Feuil1" Then Job "2", 1
End Sub

Sub SetColB()
  If ActiveSheet.Name = "Feuil1" Then Job "014", 2
End Sub

soan
 

Pièces jointes

  • excelforum.xls
    205.5 KB · Affichages: 6

soan

XLDnaute Barbatruc
Inactif
Bonjour Kayser,

Bonjour et merci à vous deux
Soan c'était ce que je voulais super encore merci

merci pour ton retour ! 😊

quand un sujet est résolu, il est d'usage de marquer comme solution le post qui t'a fourni une solution adéquate ; comme ici c'est mon post #4, tu dois faire ainsi :

Coche.jpg

toi seul peut le faire, et ça permettra aux lecteurs
d'aller directement sur le post de ma réponse.

(tu sauras si tu as réussi quand le bord droit sera en vert)

soan
 

job75

XLDnaute Barbatruc
Bonsoir le forum,

Voyez le fichier joint et les formules en D1 et E1 à tirer vers le bas :
Code:
=SI(GAUCHE(A1)="2";STXT(A1;2;99);""&A1)
Code:
=SI(GAUCHE(B1;3)="014";STXT(B1;4;99);""&B1)
Copier les colonnes D:E et collage spécial-Valeurs sur elles-mêmes pour ne garder que les valeurs.

Bonne nuit.
 

Pièces jointes

  • excelforum.xls
    223.5 KB · Affichages: 1

Membres actuellement en ligne

Statistiques des forums

Discussions
299 930
Messages
1 980 158
Membres
207 009
dernier inscrit
Cartereau