Resultat cellule vide

jeanclaude57

XLDnaute Nouveau
Bonjour à toutes et à tous.

J'ai une formule que voici :

=SI(ET(H5>=5;H5<10;TARIF!I2=0);K6;0)

Je voudrais savoir si à la place d'afficher le zero qui est en fin de formule il serait possible d'avoir une cellule vide car cela me gêne pour Concatainer un ensemble de cellules .

Ou est t'il possible de Concatainer un groupe de cellule et ne rien afficher si la cellule est un Zero?

Merci.
 
J

jocelyn

Guest
re,

je ne suis pas sur de bien comprendre situ pouvais joindre un fichier exemple ce serait plus simple

bon un essai quand même

si en B1 j'ai 'taille'
en C1 10,5

et que je concaténe en D1 j'aurais taille10,5 et mettre le format sans virgule ne change rien car le résultat de concaténer est du texte

alors la solution serait de faire une formule de ce type

=B1&ARRONDI(C1;0)

qui donne taille11

le signe & est le raccourci de la formule = CONCATENER

Jocelyn
 

MARIE74

XLDnaute Occasionnel
B) Re a tous

Bonjour jeanclaude57 et jocelyn

Bon jeanclaude57 si en A1 tu mets 5.5 en b1 tu mets 6
si tu concatene enC1 tu auras 5.56 et cela avec un format avec 'O' decimales

A l'affichage en A1 tu auras 6 mais en réalité excel travail avec 5.5

C'est normal

Bonne journée
 

Monique

Nous a quitté
Repose en paix
Bonjour,

Tu peux faire plein de choses avec la fonction TEXTE(formule quelconque;'format')
='Taille '&TEXTE(A$1;'0,00')
='Taille '&TEXTE(ARRONDI(A$1;2);'0,00')
='Taille '&TEXTE(ARRONDI(A$1;1);'0,0')
='Taille '&TEXTE(A$1;'0')
='Taille '&TEXTE(ENT(A$1);'0')

='Nous sommes en '&TEXTE(AUJOURDHUI();'mmmm')
='Nous sommes en '&TEXTE(AUJOURDHUI();'mmmm aaaa')
='Hier, on était '&TEXTE(AUJOURDHUI()-1;'jjjj')
 

Ti_

Nous a quitté
Repose en paix
le problème avec la fonction TEXTE, c'est que le format saisi entre guillemets est dépendant de la langue de l'utilisateur. Ainsi TEXTE(AUJOURDHUI()-1;'jjjj') risquera de provoquer une erreur dans un Excel qui n'est pas français.
En anglais par exemple, on n'écrirait pas 'jjjj' mais 'dddd', mais comme justement cette chaîne est entre guillemets, elle n'est pas traduite automatiquement comme le sont les fonctions d'Excel. Le problème est le même avec le séparateur décimal etc.
 

Discussions similaires

Statistiques des forums

Discussions
300 890
Messages
1 988 175
Membres
210 096
dernier inscrit
aidebatsi