XL 2019 Résolu -Souci sur formule

Fipat

XLDnaute Occasionnel
Bonjour,

Est-ce que vous pourriez m'aider sur deux formules.
Je joint un fichier exemple pour la compréhension, J10 et K10.

J'ai 3 colonnes nommées condition1, 2 et 3 et pour chaque lignes une seule de ces trois colonnes peut avoir une valeur, pour l'exemple juste un oui.
En J10 et K10 je veux afficher un résultat selon le résultat de la colonnes I.

Je ne trouve pas les erreurs.

Merci.
 

Pièces jointes

  • test.xlsx
    10.1 KB · Affichages: 7

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour Fipat,
Difficile de comprendre quand on n'a pas la finalité, "ça marche pas" c'est bien mais pas suffisant.
En PJ un essai avec :
VB:
=SI(E10="";"";
SI(OU(F10="";ET(I10>10;I10<15));"OK";
SI(D10="";"";
SI(OU(F10="";ET(I10>7.5;I10<12.5));"OK";
SI(D10="";"";SI(OU(E10="";ET(I10>10;I10<10));"OK";""))))))
Ca ne donne pas d'erreur, à savoir si cela donne ce que vous attendez . ..:)
Il y avait trop de paramètres dans les SI, de plus j'ai simplifié les ET(F10="";"") par simplement F10="".
C'est plus clair quand on met la formule sur plusieurs lignes, on voit mieux la structure.
( La mise à la ligne se fait par ALT+Entrée, cela n'impacte pas la formule )
 

Pièces jointes

  • test (10).xlsx
    9.6 KB · Affichages: 2

TooFatBoy

XLDnaute Barbatruc
Bonjour,

Cela ne fonctionne pas car le résultat ne s'affiche pas à chaque calcul.
Comme si il prenait en priorité le premier.
C'est une des remarques que j'allais faire : dans ta formule originelle, tu commences par SI E10="" alors "" donc le reste ne s'applique que si E10 est <>"" et ça, ça parait bizarre.


Mais comme l'a très justement dit Sylvanu, sans connaître la finalité du truc, difficile de dépanner une formule qui ne marche pas elle devrait... ;)

Quelles sont les conditions qui doivent donner le "OK" ?
D10<>"" et ??? je suppose que ce n'est pas ET(i10>10;i10<10) parce que i10 à la fois >10 et <10, ça ne peut pas exister. ;)

Les autres conditions doivent être, je suppose :
E10="oui" et 10<i10<15
F10="oui" et 7,5>i10<12,5


Du coup, est-ce qu'une formule dans ce genre pourrait convenir ???
=SI(OU(ET(D10<>"";i10>10;i10<15);ET(E10<>"";i10>7,5;i10<12,5);ET(F10<>"";i10>5;i10<10));"OK";"")


[edit]
Au fait... c'est quoi la différence entre la formule en colonne J et celle en colonne K ???
[/edit]
 
Dernière édition:

Fipat

XLDnaute Occasionnel
Bonjour TooFatBoy

Ce que je cherche à faire c'est de connaitre la condition remplie, colonne D,E et F et suite à cela vérifier si I10 à une certaine valeur. Une seule des trois colonnes D,E et F peut avoir une valeur (oui) par ligne

Pour la formule en colonne J
• Si D est rempli vérifier que I10 est inférieur à 7.5, si oui c'est OK.
• Si E est remplie (donc D et F vide) vérifier que I10 est inférieur à 7.5, si oui c'est OK.
• Si F est remplie (D et E vide) vérifier que I10 est inférieur à 5, si oui c'est OK.

Pour la formule de la colonne K, un peu plus compliqué
• Si D est rempli vérifier que I10est supérieur à 10 et inférieur à 15,si oui c'est OK.
• Si E est rempli vérifier que I10 est supérieur à 7.5 et inférieur à 12.5, si oui c'est OK.
• Si F est rempli vérifier que I10 est supérieur à 5 est inférieur à 10, si oui c'est OK.

J’espère que c'est plus clair écrit comme ceci.

Merci.
 

TooFatBoy

XLDnaute Barbatruc
Du coup, pour K10 je te propose ça (à tester) :
Code:
=SI(OU(ET(D10<>"";i10>10;i10<15);ET(E10<>"";i10>7,5;i10<12,5);ET(F10<>"";i10>5;i10<10));"OK";"")



Et pour J10 je te propose ceci :
Code:
=si(ou(et(d10<>"";i10<10);et(e10<>"";i10<7,5);et(f10<>"";i10<5));"OK";"")

Remarque : pour "si D est rempli", j'ai comparé i10 avec 10 et non avec 7,5 comme tu le dis en #5.
J'ai bon ??? 🤔
 
Dernière édition:

Fipat

XLDnaute Occasionnel
Merci pour votre aide, cela est fonctionnel
Le résultat souhaité est bien présent, j'ai utilisé la même formule pour la colonne J et c'est parfait.
VB:
=SI(OU(ET(D10<>"";I10>0;I10<10);
ET(E10<>"";I10>0;I10<7,5);
ET(F10<>"";I10>0;I10<5));"OK";"")
Merci.

:)
 

Membres actuellement en ligne

Statistiques des forums

Discussions
299 832
Messages
1 979 413
Membres
206 721
dernier inscrit
Sud catering