XL pour MAC Référence circulaire

meritein

XLDnaute Nouveau
Bonsoir. Je n'ai, encore, jamais vu ça. Un fichier m'affiche pour la cellule ET55 une référence circulaire qu'il m'est impossible de corriger puisque je ne la trouve pas.
Pire, la cellule de référence circulaire n'est pas "stable" puisqu'elle varie si je tape sur une, quelconque, autre cellule.
Merci aux bonnes âmes qui pourront m'apporter la solution en espérant que le fichier joint soit assez explicite.
 

Pièces jointes

  • Prob référence circulaire.xlsx
    8.8 KB · Affichages: 14

TooFatBoy

XLDnaute Barbatruc
Bonjour,

Sauf erreur de ma part :
- ET55 fait référence à AU66,
- AU66 fait référence à AH58,
- AH58 fait référence à la plage EF55:FB75 qui contient ET55.



ET55=(BW55+AU66)
Affiche 0 et référence circulaire AH58

BW55=MAX(PUTOPTION($AC55;BW54;$AH53/365;$AM$4;$AC56;0)-PUTOPTION($AC55;BW53;$AH53/365;$AM$4;$AC56;0);0,01
Résultat de cette formule 2,313

AU66=SI(NB.SI.ENS($W$5:$W$690;"<="&(AH58/$AC54)-1;$W$5:$W$690;">="&(AH57/$AC54)-1)=0;0;(AC54*(1+SOMME.SI.ENS($W$5:$W$690;$W$5:$W$690;"<="&(AH58/$AC54)-1;$W$5:$W$690;">="&(AH57/$AC54)-1)/NB.SI.ENS($W$5:$W$690;"<="&(AH58/$AC54)-1;$W$5:$W$690;">="&(AH57/$AC54)-1)))-AH58)
Résultat de cette formule -1,468782657

AH58={MAX(SI(EF55:FB75=AH59;EF54:FB54))}
 
Dernière édition:

soan

XLDnaute Barbatruc
Inactif
Bonsoir,

le schtroumpf grognon a dit :

« moi, j'aime pas les références circulaires ! » 😭


le policier Dupond a dit comme Dupont (son frère jumeau) :
«
je dirais même plus :
les références à sens giratoire, c'est mauvais pour la santé ! 😢
»
(surtout pour la santé d'Excel !)

soan
 

meritein

XLDnaute Nouveau
Bonjour,

Sauf erreur de ma part :
- ET55 fait référence à AU66,
- AU66 fait référence à AH58,
- AH58 fait référence à la plage EF55:FB75 qui contient ET55.



ET55=(BW55+AU66)
Affiche 0 et référence circulaire AH58

BW55=MAX(PUTOPTION($AC55;BW54;$AH53/365;$AM$4;$AC56;0)-PUTOPTION($AC55;BW53;$AH53/365;$AM$4;$AC56;0);0,01
Résultat de cette formule 2,313

AU66=SI(NB.SI.ENS($W$5:$W$690;"<="&(AH58/$AC54)-1;$W$5:$W$690;">="&(AH57/$AC54)-1)=0;0;(AC54*(1+SOMME.SI.ENS($W$5:$W$690;$W$5:$W$690;"<="&(AH58/$AC54)-1;$W$5:$W$690;">="&(AH57/$AC54)-1)/NB.SI.ENS($W$5:$W$690;"<="&(AH58/$AC54)-1;$W$5:$W$690;">="&(AH57/$AC54)-1)))-AH58)
Résultat de cette formule -1,468782657

AH58={MAX(SI(EF55:FB75=AH59;EF54:FB54))}
Bien vu TooFatBoy ! Pour sylvanu la fonction PUTOPTION est une macro.
Merci pour vos réponses.
 

Discussions similaires

Statistiques des forums

Discussions
299 706
Messages
1 978 625
Membres
206 312
dernier inscrit
dameli70