XL 2016 recherche information selon plusieurs critères

halimhamdi

XLDnaute Nouveau
bonjour cher ami ;
j'ai un problème au niveau recherche de nombre d'absence selon responsable pour des date bien motionné ; est ce que il ya une méthode efficace de résoudre cette problème
merci a vous tous pour vos aides et conseils
 

Pièces jointes

  • 1.xlsx
    39.6 KB · Affichages: 8

sylvanu

XLDnaute Barbatruc
Supporter XLD
Bonjour halimhamdi,
[ Re edit pour modification] Merci Vgendron, J'ai inversé les < et > !!! et c'est plus simple avec Sommeprod. Mais je ré édite quand même puisque cette autre approche marche.
( par contre je compte toutes les absences sauf B et C, alors qu'on ne doit que compter M A MP. )

Un essai en PJ avec :
Nb Blame :
VB:
=NB.SI.ENS(Tableau1[[#Tout];[responsable ]];$B$3;Tableau1[[#Tout];[statut]];"BLAME";Tableau1[[#Tout];[date début ]];"<="&A6;Tableau1[[#Tout];[date fin ]];">="&A6)
Nb Congés :
Code:
=NB.SI.ENS(Tableau1[[#Tout];[responsable ]];$B$3;Tableau1[[#Tout];[statut]];"Congé";Tableau1[[#Tout];[date début ]];"<="&A6;Tableau1[[#Tout];[date fin ]];">="&A6)
Reste absences :
Code:
=NB.SI.ENS(Tableau1[[#Tout];[responsable ]];$B$3;Tableau1[[#Tout];[date début ]];"<="&A6;Tableau1[[#Tout];[date fin ]];">="&A6)-C6-D6
Abve C6=Nb Congés et D6=Nb Blame
En utilisant toujours NB.SI.ENS et SIERREUR.
 

Pièces jointes

  • 1 V2.xlsx
    44.1 KB · Affichages: 3
Dernière édition:

JHA

XLDnaute Barbatruc
Bonjour à tous,

Je me permets ces commentaires.
Dans le tableau il y a des dates qui se terminent avant le début.
Il y a des erreurs car en congé pendant 2 ans j'ai un doute.
Des congés débutent avant le 1/06/2022 et se terminent après le 30/06/2022
problème d'espace dans la liste des responsables.

Voir le poste similaire.

JHA
 

Discussions similaires

Statistiques des forums

Discussions
300 761
Messages
1 987 019
Membres
209 681
dernier inscrit
Excelcrable