Problème valeurs intersection multiple entre des courbes

miwaka33

XLDnaute Nouveau
Bonjour à tous,


J'ai besoin d'extraire la valeur de l'intersection de deux courbes qui se croissent plusieurs fois dans un graphique.


Il s’agit de l’intersection d’un courbe déformation/temps avec des droites y=100 ; y=200 ; y=300

J’ai mis un exemple dans le fichier joint.


Pour chaque zone encercle, il me faudrait la valeur correspondante pour pouvoir faire le rapport G= deformation100/contrainte 100


Autre difficulté, il y a 18 cycles dans courbe avec chacun 7 intersections différentes.


J'aimerai aussi, si possible, que la valeur s'affiche dans un tableau


J’espère avoir été clair (pas sur !)

N’hésitez pas à me demander des précisions si nécessaire


Merci d'avance pour votre aide

 

Pièces jointes

  • exemple 1.xlsx
    535.2 KB · Affichages: 45

job75

XLDnaute Barbatruc
Bonsoir miwaka33, bienvenue sur XLD,

Joli problème, pour votre 1er post félicitations.

Voyez le fichier joint et les formules en E3 L3 M3 N3 à tirer vers le bas.

La formule en L3 est matricielle est doit être validée par Ctrl+Maj+Entrée.

J'aime bien la formule en E3 :
Code:
=SI((C3<=100)*(C4>100)+(C3>=100)*(C4<100);100/PREVISION(100;D3:D4;C3:C4);SI((C3<=200)*(C4>200)+(C3>=200)*(C4<200);200/PREVISION(200;D3:D4;C3:C4);SI((C3<=300)*(C4>300)+(C3>=300)*(C4<300);300/PREVISION(300;D3:D4;C3:C4);"")))
A+
 

Pièces jointes

  • Intersections(1).xlsx
    638.9 KB · Affichages: 39

job75

XLDnaute Barbatruc
Re,

L'interpolation donne (peut-être) de meilleurs résultats en utilisant 4 cellules et la fonction CROISSANCE :
Code:
=SI((C3<=100)*(C4>100)+(C3>=100)*(C4<100);100/CROISSANCE(D2:D5;C2:C5;100);SI((C3<=200)*(C4>200)+(C3>=200)*(C4<200);200/CROISSANCE(D2:D5;C2:C5;200);SI((C3<=300)*(C4>300)+(C3>=300)*(C4<300);300/CROISSANCE(D2:D5;C2:C5;300);"")))
Pour comparer facilement ce fichier (2) et le fichier (1), les 2 fichiers étant ouverts, onglet AFFICHAGE => Réorganiser tout.

Bonne fin de soirée.
 

Pièces jointes

  • Intersections(2).xlsx
    640.7 KB · Affichages: 32
Dernière édition:

ROGER2327

XLDnaute Barbatruc
Bonjour à tous.

Un petit coup de VBA...


ℝOGER2327
#8513


Mardi 17 Pédale 144 (Saint Dricarpe, prosélyte - fête Suprême Quarte)
21 Ventôse An CCXXV, 0,3675h - mandragore
2017-W10-6T00:52:55Z
 

Pièces jointes

  • Copie de exemple 1.xlsm
    598.8 KB · Affichages: 31
Dernière édition:

job75

XLDnaute Barbatruc
Bonjour miwaka33, Roger, le forum,

Excellente idée Roger de tracer ces 6 courbes, on voit bien ainsi les corrélations.

Du coup je les ai introduites dans mes 2 fichiers précédents, fichiers (bis) joints.

Bonne journée.
 

Pièces jointes

  • Intersections(1 bis).xlsx
    742.9 KB · Affichages: 30
  • Intersections(2 bis).xlsx
    737.8 KB · Affichages: 26

job75

XLDnaute Barbatruc
Re,

Dans le graphique de ces fichiers (ter) :

- les 4 points extrêmes, non significatifs, ont été éliminés

- sont affichés les équations et les coefficients de détermination R² des tendances logarithmiques.

On constate que :

- R² est compris entre 0,929 et 0,998, le modèle logarithmique est donc bien adapté aux mesures

- les équations et R² sont les mêmes pour les 2 fichiers *.

Le 1er fichier avec PREVISION en colonnes E et F (interpolation linéaire sur 2 cellules) suffit donc.

* Edit : je n'avais pas fait attention : les équations et les coefficients R² ne se modifient pas automatiquement quand on modifie les données, il faut reconstruire les courbes de tendance.

La conclusion reste la même : le fichier (2 ter) n'améliore pas les coefficients R², sauf très légèrement celui de la courbe "300% croissant".

A+
 

Pièces jointes

  • Intersections(1 ter).xlsx
    737.2 KB · Affichages: 29
  • Intersections(2 ter).xlsx
    738.1 KB · Affichages: 24
Dernière édition:

job75

XLDnaute Barbatruc
Bonjour miwaka33, Roger, le forum,

En supprimant la colonne E d'interpolation des Temps les équations des courbes de tendance restent les mêmes.

J'ai ajouté en AI1:AO8 le calcul des coefficients de régression a b R² et des erreurs types Sea Seb Sey.

Edit : l'erreur type sur G (Sey) étant au mieux d'une unité il est inutile d'afficher les décimales.

Fichier (3).

Bon dimanche.
 

Pièces jointes

  • Intersections(3).xlsx
    654.6 KB · Affichages: 22
Dernière édition:

job75

XLDnaute Barbatruc
Re,

La question qu'on peut se poser : pourquoi 6 courbes différentes et de si bonnes corrélations ?

En effet toutes les mesures se font a priori dans les même conditions, avec les mêmes erreurs (gaussiennes).

Cela ne peut s'expliquer que par la nature du matériau étudié et par un phénomène de relaxation.

A+
 

job75

XLDnaute Barbatruc
Bonjour miwaka33, Roger, le forum,

Le nombre de lignes de mesures en colonnes B C D peut varier d'une expérience à l'autre.

Pour éviter de redéfinir à chaque fois les courbes du graphique il faut les rendre dynamiques.

Cela se fait grâce à des noms définis, j'en ai créés 13, étudiez-les soigneusement.

Toutes les formules ont été revues.

Les 2 premières intersections sont éliminées des courbes "100% croissant" et "200% croissant".

Le mode d'emploi est simple :

- tirer la formule en colonne E sur toute la hauteur des données

- tirer les formules en colonnes L à AG jusqu'à obtenir des cellules "vides".

Fichier joint.

A+
 

Pièces jointes

  • Intersections dynamiques(1).xlsx
    662.6 KB · Affichages: 27

Statistiques des forums

Discussions
299 850
Messages
1 979 570
Membres
206 780
dernier inscrit
Edwige81