XL 2016 PROBLÈME #N/A

lapprenti

XLDnaute Nouveau
Bonjour à vous tous

Après de multiple essai avec "ESTNA", "SIERREUR" et autre je n'arrive pas à faire disparaître #N/A en D15 de la feuille RECHERCHE CLIENT.

Y a t il quelqu'un pour la solution ? Sans VAB

Et cerise sur le gâteau, quand je modifie la cellule B12 si dans la cellule B13 il y avait un "vide" avant de rechercher sur la liste déroulante cela serait génial.

Vous remerciant par avance je vous joint le fichier

Slt à vous
 

Pièces jointes

  • FICHE CLIENT.xlsm
    66 KB · Affichages: 6

job75

XLDnaute Barbatruc
Bonjour lapprenti,

Formule en D15 :
Code:
=SIERREUR(RECHERCHEV(B13;SI(B12="Monsieur";BD!L4:M16;SI(B12="Madame";BD!D4:E16;""));2;FAUX);"")
La cellule B13 contient une liste de validation donc on ne peut pas y mettre une formule.

Pour l'effacer il faut le faire manuellement ou utiliser une macro Worksheet_Change qui se déclenchera quand on modifiera B12. Mais vous ne voulez pas de VBA...

A+
 

Pièces jointes

  • FICHE CLIENT(1).xlsm
    63.6 KB · Affichages: 1

lapprenti

XLDnaute Nouveau
Bonjour lapprenti,

Formule en D15 :
Code:
=SIERREUR(RECHERCHEV(B13;SI(B12="Monsieur";BD!L4:M16;SI(B12="Madame";BD!D4:E16;""));2;FAUX);"")
La cellule B13 contient une liste de validation donc on ne peut pas y mettre une formule.

Pour l'effacer il faut le faire manuellement ou utiliser une macro Worksheet_Change qui se déclenchera quand on modifiera B12. Mais vous ne voulez pas de VBA...

A+
Merci pour votre réponse

Slt
 

Statistiques des forums

Discussions
302 039
Messages
1 999 909
Membres
214 703
dernier inscrit
christophe.dubreuil.ghi